Mailman broken

Discussion in 'Installation/Configuration' started by Sharone, Nov 22, 2016.

  1. Sharone

    Sharone Member

    Hi support,
    I tried to apt-get upgrade on my mail server (Ubuntu 14.04) and I probably broke mailman and now I get the error below in my mailq.

    ...(temporary failure. Command output: local: fatal: execvp /var/lib/mailman/mail/mailman: No such file or directory)...
    Nothing happens when I start/stop/status mailman service. Please help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to create the directory:

    mkdir /var/lib/mailman/mail/mailman
  3. Sharone

    Sharone Member

    Thank you for your response. I have done that, still nothing - mailq still growing
  4. Sharone

    Sharone Member

    Sorry, thank you, I had to change the permission for the mailman file. Much appreciated!
  5. sonik14

    sonik14 New Member

    I am having the same issue. After creating the dir, I get permission denied. I have assigned permission, but I still get the same error. All this happened after migrating to a new server using debian 11 and ISPConfig 3.2.7p1 (mailman doesn't seem to be installed, only mailman3 is installable though which is not compatible with ISPConfig as I have read in this forum). Any help?
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    sonik14 likes this.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Your problem is indeed completely different from the very old thread you posted in. Debian 11 has no mailman 2 package, that's why Debian 11 ISPConfig systems do not have mailman support.
    sonik14 likes this.

Share This Page