mailman on centos 7

Discussion in 'Installation/Configuration' started by korbynn, Dec 29, 2014.

  1. korbynn

    korbynn Member

    this setup works perfectly on centos 6.5.

    I am now setting up a CentOS 7 VPS Server.
    I am also mirroring the installation on VMWare Player.

    After fixing the mail issue now I have a mailman issue.
    Installed as per

    Error_log states that ScriptAlias line 6: will never match because the ScriptAlias at line 5 overlaps line 6 and will never be matched.

    line 5:ScriptAlias /mailman/ /usr/lib/mailman/cgi-bin/
    line 6:ScriptAlias /cgi-bin/mailman/ /usr/lib/mailman/cgi-bin/

    both work on CentOS 6.5 with no problem.

    On CentOS 7 /mailman/ -> ERROR 403 - Forbidden!
    and /mailman/anything -> ERROR 500 - Internal Server Error!
    /cgi-bin/mailman/ -> ERROR 403 - Forbidden!
    /cgi-bin/mailman/anything -> ERROR 403 - Forbidden!

    This happens on both centos 7 installs.

    The code in /usr/lib/mailman/cgi-bin/ is different for the CentOS 7 install as opposed to the CentOS 6.5 install that works. cgi-bin is owned by mailman.

    Any suggestions??????

    cgi is not working, any idea how to get it working on CentOS 7?
    Tried many fixes but no joy....:(
    Last edited: Dec 30, 2014
  2. korbynn

    korbynn Member

    Can anyone point me to this solution?
    I am even trying to get a simple outputting 'hello world' running as a web page and all it get is 403 forbidden.
    It appears that the cgi modules are loaded. is properly owned.
    CentOS 7 httpd layout is slightly different than CentOS httpd layout.
    If I can get this working then I think Mailman will work with out a problem.
  3. korbynn

    korbynn Member

    I have the perl script running after modding the vhost file.
    Added: AddHandler cgi-script .cgi .pl .py and Options +ExecCGI Follow....
    ./ and ./ run correctly from the command line but results in Error 500
    This is on my mirror. Set httpd.conf: LogLevel debug. error_log reports that /var/www/cgi-bin/mailman cannot stat. Not sure what this means.
    I guess I have a python problem on CentOS 7. Any suggestions???
  4. korbynn

    korbynn Member

    This morning I decided to see where the error for mailman happens.
    I followed the perfect server script for CentOS 7 to the letter.
    In the mean time I was checking when .php .pl and .py stop working.
    For some bizarre reason even though the perl and python scripts worked from the commandline I could not get the to work in the browser. It insisted on downloading the script.
    I noted that the .php script info.php stopped being parsed as soon as I installed the suphp stuff.
    mailman was fully functional and my hellow world script worked without problems.
    As soon as I created a website in ispconfig all mailman and my script plus my info.php script came up with error 500.
    This is done on my vmware virtual machine.
    Not sure what is happening. Something in the ispconfig script breaks everything!!!!
    Any thoughts on the subject? Anyone??? What do I need to look at.
    I cannot reinstall everything on the target server since it is being used. I just need to figure out how to fix the python/suExec issue.
  5. korbynn

    korbynn Member

    Found a solution. I guess I am blind.
    Did not understand where the CGI and suExec issues. Found that when you create a website with CentOS 7 the suExec is auto checked, on my CentOS 6.5 the suExec is not checked and does not seem to make a difference on my CentOS 6.5 setup to access mailman.

    In httpd.conf I commented out the /cgi-bin/ reference at line 247 this enabled/cgi-bin/mailman/.
    till likes this.
  6. korbynn

    korbynn Member

    What do I do with this:
    acommand failed: /etc/mailman/ /etc/mailman/virtual-mailman (status: 127, Key has expired)
    And where do I get a copy of /etc/mailman/
    Is it dynamically generated?
  7. korbynn

    korbynn Member

    created /etc/mailman/ with the suggested 3 lines.
    sed -r -e 's/(^[^#]\S+\s+).+$/\1local/' $1 > /var/lib/mailman/data/transport-mailman
    /usr/sbin/postmap /var/lib/mailman/data/transport-mailman
    I have added my lists through ispconfig - version
    it appears that the lists are bouncing.
    I hard linked /var/lib/mailman/data/aliases to /etc/mailman/aliases issues with timestamps and aliases.db in that dir not being updated. aliases appears to update timestamp is still wrong.
    the new mailing lists are bouncing but the mailman list is not. Only issue mailman mailing list is not being delivered.
  8. korbynn

    korbynn Member

    I think I have done everything I can with mailman config.
    I can admin the lists but if I subscribe to a list the subscription is stuck in /var/lib/mailman/lists/list/pending.pck.
    Could this be a python error? my hello world script in the browser displays the contents of the file which I know is a problem if I want to run some python scripts. The irony is that the perl script works no problem.
    Any thoughts on the subject?
  9. korbynn

    korbynn Member

    this seems odd, i did a:
    mailman is now working except all outside domains are be blocked.
    Added my ip to the mynetworks = myip/32,
    but no joy at this time
    Need to find the last occurrence of mynetworks in the file!!
    Last edited: Jan 4, 2015
  10. korbynn

    korbynn Member

    Added a test mailing list to test relay.
    Even though the I can modify the list, when I add another mailing list the list does not transfer to the aliases.
    the email to the test mailing list ends up in my catch all mailbox.
    I have joy the required mailing lists and in place and working.
    Sorry about my ramblings.
    At least next time I have this information some where on the network that I can refer to.
  11. smartmobili

    smartmobili New Member

    I am not using mailman for the moment but I have noticed the error you mentioned inside my logs too.
    Thanks for trying to find a solution and I hope ispconfig developer will fix it soon...

Share This Page