mailman throwing cgi errors

Discussion in 'Installation/Configuration' started by Curtis Maurand, Nov 22, 2019.

  1. Hello,
    I haven't actually tried to make this work until now and I've been using ispconfig for several years. worked on getting the mailman web gui to work. the paths defined for the cgi-bin were wrong. the cgi-bin on the debian stretch gets created in /var/lib/mailman/cgi-bin not /usr/lib/mailman/cgi-bin. it didn't matter, because that simply didn't work. I copied the cgi-bin files to the vhost for the tld's cgi-bin/mailman folder. changed the permissions and ownership as per instructions in another forum post. I went from not found to cgi-errors. the logs are giving a whole lot of nothing:

    [Fri Nov 22 13:29:18.255384 2019] [cgi:error] [pid 31806] [client] AH01215: \tREMOTE_PORT: 43506: /var/www/clients/client1/web1/cgi-bin/mailman/admin
    [Fri Nov 22 13:29:18.255493 2019] [cgi:error] [pid 31806] [client] AH01215: \tHTTP_ACCEPT_LANGUAGE: en-US,en;q=0.5: /var/www/clients/client1/web1/cgi-bin/mailman/admin
    [Fri Nov 22 13:29:18.255526 2019] [cgi:error] [pid 31806] [client] AH01215: \tREQUEST_SCHEME: https: /var/www/clients/client1/web1/cgi-bin/mailman/admin
    [Fri Nov 22 13:29:18.255569 2019] [cgi:error] [pid 31806] [client] AH01215: \tHTTP_ACCEPT_ENCODING: gzip, deflate, br: /var/www/clients/client1/web1/cgi-bin/mailman/admin

    The web page is giving even less:
    Bug in Mailman version 2.1.23
    We're sorry, we hit a bug!
    Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.

    any ideas?
  2. Steini86

    Steini86 Active Member

    I am no longer using mailman, but I remember having a lot of problems with this web interface (one of the reasons, I am no longer using it). I just looked to my (deactivated) setup and it was as follows:
    (own subdomain for mailman, should not be necessary)
    additional apache config:
    # Logos:
    Alias /images/mailman/ /usr/share/images/mailman/
    ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/
    <Directory /usr/lib/cgi-bin/mailman/>
        AllowOverride all
        Options +ExecCGI
        AddHandler cgi-script .cgi index.cgi
    Require all granted
    <Directory /usr/share/images/mailman/>
        AllowOverride all
    Require all granted
    However, I do not know if that would still work and if I changed something else. (For sure you have to adjusts the paths to your /var/lib/mailman/cgi-bin )
    Hope it helps though..

Share This Page