Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.


Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    220 vote(s)
  2. No

    3 vote(s)
  1. wolfiedk

    wolfiedk New Member

    Damn, I´m stuid, sorry for wasting your time, it was a configuration issue again.

    The soap url was wrong, its should say :8080/ispconfig/remote instead of :8080/remote.

    Case closed!
  2. wolfiedk

    wolfiedk New Member

    Danish translation


    I have made a danish translation of the plugin's.


    Best regards

    Attached Files:

  3. drewb0y

    drewb0y Member

    Switch from branch to trunk question - resolved

    If I previously installed the plugins from SVN using the early instructions which pointed to branch, can I update to trunk by simply using

    svn co . 
    Or will this cause issues?

    Currently running roundcube 0.4.2 but preparing to update to 0.5.3

    Thanks in advance for any replies

    Update- resolved
    I ended up just duplicating the current roundcube install directory
    Then I manually updated/reinstalled all the plugins using SVN
    Then I updated roundcube itself. After testing it all out I replaced the original old roundcube dir with the new updated one.
    Now I can update properly using
    svn up .
    from within the plugins dir
    Last edited: Jul 15, 2011
  4. admins

    admins Member

    Hi all

    I've updated the rc to 0.5.3, after that i've updated to trunk revision 113.
    If I now add a autoresponder, add the date and push to save it didn't saved it. It's displaying again 0000-00-00 00:00:00.

    All other functions work fine...
    How can I fix that. Thanks horfic for your work!
  5. wolfiedk

    wolfiedk New Member

    Hi admins!

    I dont know why the update package dont update the autoreply files, but heres how I did it:

    1. Downloaded the update file (links is on one of the previos pages)
    2. Extracted it
    3. Choosed yes to overwrite the files in ipsconfig3_autoreply folder.
    4. Then the date works perfect.

    Best regards
  6. admins

    admins Member

    Thanks that worked fine.
    Another problem, if I access the rc with example firefox with german language, it displayes the plugin part in english the orginal rc part is german...

    How can I correct this?

  7. Reno

    Reno New Member



    I am using ISPCP RC 0.5.3 and the version of the plugin in the trunk but

    I still have the connection issue if I fill the "default_host" line in the main file of RC...

    This is not a big issue, but it is pretty annoying as I got like a lot of mail server...

    Thank you
  8. daben

    daben New Member

    thank you.

    For security reasons it is important to export the plugin-files of the subversion or delete the .svn folders after the checkout.
    Otherwise, these directories are accessible (when using incorrect permissions). Attackers can gain information about internal structures (e.g. /webmail/plugins/.svn/entries).
    Another way to circumvent this problem is setting an Apache Directive.
    <DirectoryMatch \.svn>
       Order allow,deny
       Deny from all
  9. GTB

    GTB New Member

    I am running the latest roundcube 0.5.4 on a Debian Squeeze and habe checked out from trunk the plugins.

    Now if I login to rc go to the account tab I get alwas the message:

    Regards GTB
  10. nveid

    nveid New Member

    First off GTB.. I got that too at first, that was due to me putting int hew wrong address in the soap client. mine is at https://myaddress:special port.. Double check the address you have put in there.. Maybe thats your problem too.

    Overall I like this plugin.. One minor issue though, I use a special theme with my round cube branded for my server, your "skins" go off the skin setup for round cube. Perhaps you could adjust the code if the plugins/ispconfig_whatever/skins/sometheme doesn't exist, it reverts back to default?

    Another minor suggestion, if someone doesn't have access to certain functions. Don't give display the menu.
  11. nveid

    nveid New Member

    I'm getting this error when I try to make any changes with the roundcube module.

    Soap: login_error_regex
  12. erosbk

    erosbk New Member

    Awesome (and usefull!) plugins!!!

    I have a problem with autoreply plugin. It saves message and "enabled" status, but it is not saving startdate/enddate into database. From ISPConfig it is working ok.

    I am using Debian 6, RC 0.3.1 and ISPConfig

    Best regards and thanks in advance for your help!
  13. jtheed

    jtheed Member

    I got this to work by creating a temp directory under the plugins directory and changed the svn to this. I made the temp directory because they would not download directly into the plugins directory due to the originals coming from the branches.

    svn co .

    Then copied them over the existing ones in the plugin directory and now the date/time entries work.

    Back your directories up first as I am using RC 4
  14. osterhase

    osterhase New Member

    Hey Horfic!

    Thanks for your great work. We have a request and maybe you could help us out: We are interested in singleing out the the ispconfig3_wblist as a standalone-plugin - so to make an own plugin out of it, so that is actually usable without installing ispconfig3_accounts (it seems too mighty to us and we also have a set of other plugins installed so that the additonal tab would confuse our - often rather stupid - user). We stumbled a bit around in your code but were not really able to get it properly integrated into the settings tab...

    Maybe you could give us a hand here?

    Attached are our weird tries to get this plugin working the way we wanted it. Help would be very much appreciated.

    Attached Files:

  15. erosbk

    erosbk New Member

    Thanks!!! I downloaded from svn you posted, and just edited original autoreply file with modifications from yours (just a few lines with startdate and enddate formatting) and it is working perfectly ;)
  16. SilentHunter

    SilentHunter New Member

    SOAP Error: Forbidden

    Hey guys, there are some people who have "SOAP Error: Forbidden" and I solved the problem ;)

    It is not the plugin, it is mod_evasive from apache. Just do not make it to sensitive and the Error is gone!
  17. GTB

    GTB New Member

    I have the same problem. Has someone an idea how to solve ?

    Regards, GTB
  18. mahcis

    mahcis New Member

    The same problem for me.
  19. petercyyau

    petercyyau New Member

    squirrelmail plugin display varialbe names: acc_general

    Dear all,

    I installed the squirrelmail plugin with the correct version described in the tutorial/forum, where I find it run well but the hyperlink a href name all displayed the variable name like: "acc_general acc_pass acc_fetchmail acc_forward acc_autoreply acc_wblist" instead what it should be correctly display like" General, Password", etc.

    Any hints about this? Thank you.

  20. pszemaz

    pszemaz New Member

    What did you do exactly?
    I have problems with dates when using plugin ispconfig3_autoreply and ispconfig3_forwarder.
    When I set what I want in autoreply, all data in database is ok, but then when I set although mail to forward and SAVE, then dates (start, end) from autoreply are gone (0000-00-00 00:00 ... ).


Share This Page