mb2md problems

Discussion in 'Installation/Configuration' started by godsdog, Sep 4, 2006.

  1. godsdog

    godsdog New Member

    Hi, I backed up all the user email files before performing a fresh install, and now trying to convert those files to maildir format.

    I have mb2md installed and it constantly returns errors
    perl mb2md-3.20.pl -s someone -d /var/www/www.domain.ca/user/someone/Maildir/
    Fatal: Source is not an mbox file or a directory!
    I'm left beleiving that my source files are not mbox...however I've popped one of the files open and notice that the emails are all separated by a
    line so it's more than likely me. Please help.
  2. sjau

    sjau Local Meanie Moderator

  3. godsdog

    godsdog New Member

    This is the page I've been working from and it's pretty straight forward. I'm trying to figure out why my source file is apparently not mbox format. thanks anyways.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you tried the "-c" option? It might help if your mbox format is not recognized correctly.
  5. godsdog

    godsdog New Member

    I've tried that with the same results.
  6. falko

    falko Super Moderator ISPConfig Developer

    The mails should be separated by blank lines...
  7. sjau

    sjau Local Meanie Moderator

    Hmmm, if the mails should be separated with a blank line you could do the following:

    Have a script replace this

    by a blank line.
  8. godsdog

    godsdog New Member

    There are many blank lines throughout the text file and I'm left believing this was not a standard file created by ISPconfig and is impossible to run a script on.

    What I did was setup the old email server with an internal ip, and create both old and new email accounts in good ol' Outlook Express using IMAP and just clicked and dragged from inbox to inbox, changing the account names as I went along.

    I am now a fan of maildir.

Share This Page