Migration of users from linux-fedora to ldap server!

Discussion in 'Suggest HOWTO' started by Jyotishmaan, Nov 17, 2007.

  1. Jyotishmaan

    Jyotishmaan New Member

    Dear All Openldap USERS,

    This is Jyotishmaan Ray, from Silchar, India.

    I have been working on migration of users from fedora-linux server to LDAP server. Of late after i have migrated all users, as per the administration guide of openldap sofware, i realised that i have done something wrong, because of which the authentication is not successfully happening.

    Attention please, all openldap experts who are on linux-fedora platform please give you kind attention to my questions:-

    1) Is it necessary to execute the following steps :-

    Now you are ready to migrate the data (actually it works even without the export command):

    export ETC_SHADOW=/etc/shadow
    ./migrate_base.pl > /tmp/base.ldif
    ./migrate_group.pl /etc/group /tmp/group.ldif
    ./migrate_hosts.pl /etc/hosts /tmp/hosts.ldif
    ./migrate_passwd.pl /etc/passwd /tmp/passwd.ldif

    Now we have the data in the format understood by LDAP server. Please open one the files with text editor to get used to the syntax. After that we can add the data from ldifs.

    ldapadd -D "cn=Manager,dc=domain,dc=com" -W -f /tmp/base.ldif

    ldapadd -D "cn=Manager,dc=domain,dc=com" -W -f /tmp/group.ldif

    ldapadd -D "cn=Manager,dc=domain,dc=com" -W -f /tmp/passwd.ldif

    ldapadd -D "cn=Manager,dc=domain,dc=com" -W -f /tmp/hosts.ldif

    However, i have not performed all the above steps except for the addition of users(ldif files after converting by using perl script)!!

    As of now, when i finger the users, it shows fine. But when i try to log ion to the server machine using

    ssh localhost.localdomain. -l xyx,


    ssh "hostname" -l xyz

    it prompted me the password twice one trial after another and subsequently throwing the message as shown below:-

    [[email protected] bin]# ssh authdns.nits.ac.in -l jmaan
    [email protected]'s password:
    Permission denied, please try again.
    [email protected]'s password:
    Permission denied, please try again.
    [email protected]'s password:
    Permission denied (publickey,gssapi-with-mic,password).
    [[email protected] bin]#

    After seaching on the google.co.in, i have changed the default permission of the file /dev/tty (666) to 777.

    Still it is not successfully working with ssh. I just wanted to make it sure that i could log in with user locally, to my server. However, the /etc/passwd file does not show the passwd field of the users as 'x' but rather as '*'.

    To check this i have tried using the command,

    getent passwd|grep user

    it worked fine.

    Please tell me is it because i have not performed the first few steps of ldapadd of (locals machine's) base.ldif, hosts.ldif, group.ldif to the ldap server that, its not working.

    I have also worked with the command:-


    to generate the new shadow file from the /etc/passwd file.

    Please help!!

    Also, i have one more question, how much time does the linux-fedora takes to show up all the migrated users in the GUI of LINUX-FEDORA, once all the users have been migrated in LDAP DATA EXCHANGE FORMAT.


    [email protected]

    Edit/Delete Message;)
  2. falko

    falko Super Moderator ISPConfig Developer

    Please don't double-post.
  3. jelutz

    jelutz New Member

Share This Page