mod_geoip, help needed for setup

Discussion in 'Installation/Configuration' started by bg011ca, Feb 15, 2008.

  1. bg011ca

    bg011ca New Member

    Hello there.

    I have version 2.2.18 on CentOS 4.5.

    For last couple of days I am trying to figure out how to use GeoIP for redirection and I am stumbled upon installation of mod_geoip for Apache server

    I was following instructions from here: and here:

    I can not pass line of
    "apxs -cia -I/usr/local/include -L/usr/local/lib -lGeoIP mod_geoip.c"

    as "bash: apxs: command not found"

    Only apxs I could locate in "/root/ispconfig/httpd/bin" folder.

    Help is very much appreciated.

    Please and Thank You.
  2. topdog

    topdog Active Member

    Include "/root/ispconfig/httpd/bin" in your PATH
    export $PATH
  3. bg011ca

    bg011ca New Member

    I tried...

    ... to include whoule path when running command,
    "/root/ispconfig/httpd/bin/apxs -cia -I/usr..."
    with no success.

    I have tried to run originaly suggested line from the "/root/ispconfig/httpd/bin" folder as well, no success.

    I do not know if problem might be due to the Apache 1.* usage for ISPConfig and Apache 2.* and mod for that Apache version that I am trying to set up.

    Does "apxs" command care for version of Apache that it is supposed to be used for?

    Additional info for my setup is that before loading ISPconfig, I have run perfect setup for CentOS 4.5.

    All worked fine using howtoforge guidelines.
  4. falko

    falko Super Moderator ISPConfig Developer

    Please install the httpd-devel package:
    yum install httpd-devel
    and then search for apxs:
    locate apxs
  5. bg011ca

    bg011ca New Member

    That worked.

    Falko, thanks.

    You are the boss.

    Now, mod_geoip is loaded on server level.
    Users can use it via local .htaccess with and, at the same time, decide which database to use via:

    GeoIPEnable On
    GeoIPDBFile /path/to/GeoIP.dat


    Or that can be configured on the server level as well.

    Thanks, again.

Share This Page