mount network drive over cifs in /etc/fstab run into problems

Discussion in 'Installation/Configuration' started by Frankenstein, Sep 30, 2018.

  1. Frankenstein

    Frankenstein Member

    Hey Guys,

    since yesterday afternoon i try to mount a hetzner storage box to the control.domain.tld (the webserver).

    I've done the following:

    nano /etc/fstab
    into a newline:
    // /storage-box-one cifs defaults,username=USERNAME,password=PASSWORD,uid=1005,gid=1003

    For the definition:
    the network storage: // /storage-box-one
    protocol: cifs
    -->defaults = rw,suid,dev,exec,auto,nouser,async
    -->username = username of storage box
    -->password = password of storage box
    -->uid= using the user web5 (that is where i need to have rights to the content on the storage box)
    -->gid= using the group of the client1 (that is where i need to have rights to the content on the storage box)

    save, exit & reboot the system

    After restart the partition is there without any warnings/errors on "dmesg". I've created the folder "data" on it, which should used by the nextcloud installation. So i've changed the chown to 1005:1003 recursively and made a chmod 755 to the folder.

    But if i try to install the "data" directory to that with the nextcloud installer its saying "U dont have the permissions to write to the data folder."

    Just for the info:
    i've tested it with a little minimum system with a lamp base system and the user:group www-data:www-data which is working. Doing the same to the control doesnt worked.

    What i've tried:
    uid/gid = 1005:1003
    uid/gid = www-data:www-data
    without uid/gid
    without creating data folder before, just chmod and chown to /shared-cloud-1 in all combinations with above

    Did anybody has a clue?

    Best regards
  2. Frankenstein

    Frankenstein Member


    Perhaps i need to configure "relative symlinks" and "Network file system" as checked in server configuration of the web server?
    Or eventually just "relative symlinks" OR "Network file system"?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not related, leave these settings as the are.

    What is the exact mount point that you used? I would mount it into the private folder of the site. Example:

    // /var/www/clients/client1/web1/private/data cifs defaults,username=USERNAME,password=PASSWORD,uid=1005,gid=1003

Share This Page