Moving ISPConfig - New thread

Discussion in 'Tips/Tricks/Mods' started by Numerizen, Mar 25, 2009.

  1. Numerizen

    Numerizen Member

    Hello all,

    I just ended the process of moving my ISPConfig enabled server from one VDS to another and thought it might be cool to tell others about my experience, as limited as it may be.

    I based my work on this thread :

    It is a little outdated and cluttered with support requests of various types, so I'll try to summarize what I found inaccurate.

    All the stuff about tar.gz files, sql dumps, copying lines from old files to new ones and forwarding mail from old to new remains valid.

    For moving dumps and archives from one server to another, wget is your best bet. Simply move the files to a directory accessible via web, go to the right directory on the new server, and type :


    The line about users in the new db I didn't understand, so my guess is that the databse changed a lot since this post.

    Also, as mentioned in the old thread, I had to copy debian.cnf to the new server to keep the things together with the encrypted version of the password in the database (see here :

    I had a hard time updating the DNS stuff. I first copied the pri* zone files, but they got updated and the new info was replaced by the old one. I then checked the database and had to update manually a lot of tables. I just replaced every occurence of the old IP with the new one, in every table I could find.

    I didn't have to mess with the mails as I use Maildir.

    Also, I didn't have to use the line mentioned here : but you might.

    Things seem to work now, but some of my domains are not migrated yet. Whois and dig infos are good, so my guess is propagation is not yet done for all of them.

    Hope this thread will be useful to some. Thanks to all posters in the original thread.
  2. Numerizen

    Numerizen Member

    Some doubts

    Just to keep this thread up to date, here is some new information.

    All my domains migrated fine. I'm a reassured webmaster.

    Then, I have a problem at my new hosting : mysqld shuts itself down from time to time.

    I tried to investigate a bit, and tweaked a few parameters, but the problem seems to keep on.

    I then stumbled on this thread : and doubted.

    I don't know if it can be linked to the moving of ISPConfig, but one idea seems important to me : you have to disable cronjobs ran by ISPConfig on the old server as long as you keep it online.

    On my setup, several cronjobs were ran using lynx to call the cron.php on several of my Drupal websites. I don't think my problem lies here, but it could be an issue if cronjobs ran by ISPConfig for its internal maintenance kept calling routines on the new server.

    One thing of which I'm not sure but was thinking about : the shutdowns SEEM to happen when I'm working on ISPConfig. Could it be ?

    Don't know if anything I say is sound, but Till or Falko will tell, I hope.

    Anyway, if anybody has any idea why my mysqld is shutting itself down now and then, I would be happy and interested to read it.

    For the record, here's the log for a typical crash (I deactivated the innodb stuff in my.cnf but no luck) :

    Mar 27 15:46:34 web mysqld_safe[26113]: Number of processes running now: 0
    Mar 27 15:46:34 web mysqld_safe[26115]: restarted
    Mar 27 15:47:43 web mysqld[26118]: 090327 15:47:43 [Note] /usr/sbin/mysqld: ready for connections.
    Mar 27 15:47:43 web mysqld[26118]: Version: '5.0.32-Debian_7etch8-log' socket: '/var/run/mysqld/mysqld.sock' port: 33$
    Mar 27 15:51:56 web mysqld_safe[26419]: Number of processes running now: 0
    Mar 27 15:51:56 web mysqld_safe[26421]: restarted
    Mar 27 15:51:59 web mysqld[26424]: 090327 15:51:59 [Note] /usr/sbin/mysqld: ready for connections.
    Mar 27 15:51:59 web mysqld[26424]: Version: '5.0.32-Debian_7etch8-log' socket: '/var/run/mysqld/mysqld.sock' port: 33$
    Mar 27 16:30:46 web ntpd[5443]: synchronized to, stratum 2
    Mar 27 16:55:22 web mysqld_safe[28281]: Number of processes running now: 0
    Mar 27 16:55:22 web mysqld_safe[28283]: restarted
    Mar 27 16:55:26 web mysqld[28286]: 090327 16:55:26 [Note] /usr/sbin/mysqld: ready for connections.
    Mar 27 16:55:26 web mysqld[28286]: Version: '5.0.32-Debian_7etch8-log' socket: '/var/run/mysqld/mysqld.sock' port: 33$
    Last edited: Mar 27, 2009
  3. Numerizen

    Numerizen Member

    Here's my guess about the problem :

    I forgot to upgrade my installation before dumping my database. So, on the new server, I had a 2.2.29 install with a 2.2.25 database.

    I upgraded the new install from 2.2.29 to 2.2.30 and hope it will do the trick. The process went fine.

    Just after the upgrade, a process called grpconv ran and ate as much as 70% memory. I wonder if this process tried to run when I saved changes in ISPC. It would partly explain the hangs.

    I hope I solved the problem with the upgrade, but I would like to read if somebody more competent than me could propose an explanation.
  4. Numerizen

    Numerizen Member

    Ok, I ran into this problem :

    Fact is I messed up something copying lines in shadows and group, so there were discrepencies.

    Running grpck (not grpchk as in linked thread) and pwck did the trick.

    Now grpconv returns instantly with no error.

    The server doesn't seem to hang anymore when saving changes from ISPConfig.

    Hope it wiil be the last update of this thread.

Share This Page