Multiple IPs running SSL: config error

Discussion in 'Installation/Configuration' started by benbalbo, Nov 18, 2005.

  1. benbalbo

    benbalbo New Member

    I just had problems getting a new certificate to work, and noticed that the Vhosts_ispconfig.conf had:

    But the SSL port (443) had no NameVirtualHost entries.

    I greped the source to find any occurances of NameVirtualHost and only found it in one place. I've tried to fix this by changing /root/ispconfig/scripts/lib/config.lib.php at line 1230 from:
            $mod->tpl->assign( array(SERVERIP => "NameVirtualHost ".$ip["server_ip"].$web_port));
            $mod->tpl->assign( array(SERVERIP => "NameVirtualHost ".$ip["server_ip"].$web_port),
                               array(SERVERIP => "NameVirtualHost ".$ip["server_ip"].$ssl_port));
    But this hasn't solved the problem.

    I'm going to delve into the template class now to see if I can see how it works and what I need to do to fix this issue. Any tips, pointers, advice, existing patches would be very welcome :)

  2. benbalbo

    benbalbo New Member

    Well I'm not sure what happened, but after restarting apache manually without the NameVirtualHost 443 in the conf file, the certs still work properly.

    I'm still confused however about the error message:
    [warn] VirtualHost overlaps with VirtualHost, the first has precedence, perhaps you need a NameVirtualHost directive
    grepping the whole /etc/apache2 directory and below for VirtualHost shows there is only one definition for each IP on port 443, so I'm not sure why the warning says there are two. However, it's only a warning and the sites work, so I'm not too fussed right now.
  3. falko

    falko Super Moderator Howtoforge Staff

    Can you post your Vhosts_ispconfig.conf?

Share This Page