multiserver broken on migration - HELP! no mysql for ispconfig@localhost

Discussion in 'ISPConfig 3 Priority Support' started by Turbanator, Apr 25, 2015.

  1. Turbanator

    Turbanator Member HowtoForge Supporter

    Perfect Wheezy - courier - apache2.
    a few weeks ago I posted how I upgrade master server just fine.
    Last night I migrated email server and now I can SEND email but not receive
    before I worry about that, I current cannot access local mysql for user 'ispconfig'@'localhost'.
    I changed the ispconfig password in /usr/local/ispconfig/server/lib/
    I changed the permission in mysql to match and verified that I can mysql -uispconfig -pmypassword just fine., update.php, mail.log, mysql.log all show that ispconfig cannot connect to mysql locahost.

    What am I missing?
  2. Turbanator

    Turbanator Member HowtoForge Supporter

    So I think I for the ispconfig@localhost issue fixed, but I now have :
    Unable to load the server configuration from database

    Emails aren't being received due "Relay access denied" my guess is due to NOT reaching Master server?

    jobqueue stuck with nothing clearing after resync of Mailboxes...100 pages worth.

    I was thinking to remove server2 (email server) as a valid server in ispconfig control panel, but I wasn't sure if that would break any setting with emails (all pointing to server2 already) and then setup it up again.

    Any help would be appreciated.
    Last edited: Apr 26, 2015
  3. Turbanator

    Turbanator Member HowtoForge Supporter

    update: i think I have it working. emails are coming in and jobqueue has flushed through. The problem was, of course, mysql.user password problems between servers, but also server_id was mismatched after reloading dbispconfig from backup after the migration. The key was to change the server_id in /usr/local/ispconfig/interface/lib/ AND /usr/local/ispconfig/server/lib/ . And this was due to me wanting to keep the existing server_id's instead of incremental as ispc wanted to this was really all my own fault.

    Maybe this will help someone...and me again, in the future.

Share This Page