Multiserver setup on CentOS7, bind not loading zones

Discussion in 'Installation/Configuration' started by outsiding, Nov 26, 2014.

  1. outsiding

    outsiding New Member

    First thanks to all contribuited to form this software.... amazing!!!

    We are a Swiss Start-Up company, and would like to use ISP-Config.

    We created a 7-Server setup...

    control.mydomain (interface)
    db1.mydomain for mysql for clientdb

    All seem to work, exept for the ns-servers... It seem the folder where the zones were created from ispconfig wont be loaded:

    I guess the directorysctructure in the install.php of ispconfig install presume to install it on a server with jailkit or something like this...

    I tried to enter the directory in named.conf but nothing happend, also tried to set ownership to that chroot directory ascendent with -R root:named with permission 770 but nothing....
    if I do a rndc dumpdb -zones I see just this:

    [root@ns2 data]# vi cache_dump.db
    ; Start view _default
    ; Start view _bind
    ; Zone dump of 'authors.bind/CH'
    ; not implemented
    ; Zone dump of 'hostname.bind/CH'
    ; not implemented
    ; Zone dump of 'version.bind/CH'
    ; not implemented
    ; Zone dump of 'id.server/CH'
    ; not implemented
    ; Dump complete

    I tried to reinstall the server with jailkit enabled, but also nothing... named dont load the zones :-(

    Any help would be appreciated....

    Thanks a lot for this fantastic panel... I'm pretty sure I did something wrong, or maybe my configuration in this setup is not yet implemented in some way ;-)

    Grüsse aus der Schweiz
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. outsiding

    outsiding New Member

    Wow... what a fast answer

    Hello Till

    Could not belive you answer as fast as you did ;-)

    Sorry, i didnt find that post... I also brought a six-month subscription, and I also missed that part on page 231 of the manual:eek: ;-) I'm really sorry for that newbie fault ;-) I've searched tooo far away...

    But now I've another question, and I'm sure there is no mention anywhere:

    Where can I change the mailflow of the ISPC-Interface-server... I dont want the Interface-Server sending mails directly, it should send it through my smtp...
    I already configured the smtp as mirror of the mailserver, and I configured postfix to not hold local mailboxes, nor doing local delivery...
    I also changed the smtp for roundcube but cant find where to change it for the ispconfig-interface...

    Are there other mails sending out from a server I missed to configure?
    I didn't install mailman, I dont want my user misusing an IP to get then blacklisted...

    Thanks a lot
  4. outsiding

    outsiding New Member

    I must mention, I tried it with the email-routing feature, but it dont seem to work...

    I guess I cant use the mail-routing for that feature, isn't it?

    But can I use this feature on my pop-server forwarding the mails for all domains to the smtp?(vacation, autoresponder, etc...)

  5. outsiding

    outsiding New Member

    I found now the file

    I filled in the smtp variables, but still sending out by localhost :-( also rebooted the server, but still sending localhost

    maillog:Nov 27 03:41:03 control postfix/smtp[2461]: 6A26F60D0013: to=<[email protected]>,[]:25, delay=0.92, delays=0.11/0.01/0.19/0.61, dsn=2.0.0, status=sent (250 Requested mail action okay, completed: id=0MPJ7s-1XpRIE3wDQ-004QUe)

    Header of the incoming mail:
    Return-Path: [email protected]
    Received: from ([]) by
    (mxgmx104) with ESMTP (Nemesis) id 0M19RE-1YDXmx09JA-00tCf6 for
    <[email protected]>; Thu, 27 Nov 2014 03:41:03 +0100
    Received: by (Postfix, from userid 1001)
    id 6A26F60D0013; Thu, 27 Nov 2014 03:41:02 +0100 (CET)
    To: [email protected]
    Subject: =?UTF-8?B?bmFjaCByZWJvb3Q=?=
    MIME-Version: 1.0
    User-Agent: ISPConfig/3 (Mailer Class)
    From: <[email protected]>
    Content-Type: text/plain; charset="utf-8"
    Message-ID: <[email protected]>

    Changements i made in
    private $use_smtp = true;
    private $smtp_helo = '';
    private $smtp_host = 'smtp1'; (short Name for using internal IP)
    private $smtp_port = 25;
    private $smtp_user = '[email protected]';
    private $smtp_pass = 'mypassword';
  6. florian030

    florian030 Well-Known Member HowtoForge Supporter

    Why don´t you use a relay-host?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    No changes in ispconfig code are required, all you have to do is:

    1) On the controlpanel server, set:

    relayhost =

    in the postfix, where is the IP address of your mail server node.

    2) On the mailserver node, add the IP address of the controlpanel node in the mynetworks line and restart postfix.
  8. outsiding

    outsiding New Member

    Thanks a lot! It worked!

Share This Page