Multiserver sync is not working

Discussion in 'Installation/Configuration' started by mccyberix, Apr 4, 2017.

  1. mccyberix

    mccyberix Member

    I have a 3 node multiserver setup which is actually working fine, but I had on one node some issues and have reinstalled the ISPConfig3 (only on one node)... the reinstallation have messed up the passwords in several config files, I have corrected them manually and everything seems to work fine except the synchronisation between the master ISPConfig3 server and one of the slaves. I guess I have overlooked some internal ISPConfig3 settings which are responsible for the master/slave sync.

    is there anybody who can provide me with a checklist with the necessary settings for master/slave synchronisation, I guess the issue is related to the "ispcsrv" user which is automatically generated during setup...

    thanks in advance!
  2. mccyberix

    mccyberix Member

    I have solved the issue by myself...
    I have tried to exclude the server which was not synced from mirroring in the ISPConfig3 on the master server panel but without success, the task was cued and did not finish, then I tried to assign the server again as mirror of the master but it only cued up a further task which also did not complete...

    after waiting for 1h the tasks where still in the cue...

    then I've decided to delete the not synced server from the master and uninstalled also the ISPConfig3... (I left the websites and mailboxes untouched)

    then I have reinstalled the ISPConfig3, configured it again as mirror of the master and run the resync process...

    this have solved the sync issue but I had also to reconfigure my services since the custom config files where overwritten during the reinstallation of ISPConfig3.
    ahrasis likes this.

Share This Page