MyDNS fails to start

Discussion in 'Installation/Configuration' started by tristanlee85, Mar 14, 2010.

  1. tristanlee85

    tristanlee85 New Member

    I've noticed in the ISPConfig 3 monitor it shows MyDNS as being off-line. Upon trying to start the service, I get this:
    [[email protected] ~]# /etc/init.d/mydns restart
    Stopping mydns:                                            [FAILED]
    Starting mydns: mydns[2085]: Error connecting to MySQL server at localhost: Access denied for user 'username'@'localhost' (using password: YES) (errno=0)
    Here is my start-up config:
    [[email protected] ~]# chkconfig --list | grep mydns
    mydns          	0:off	1:off	2:on	3:on	4:off	5:on	6:off
    I recall in the documentation to set this up that the password would be set during the ISPConfig installation. I ran update.php to re-configure everything, ensuring I didn't leave anything incorrect. Still, the service won't start.

    Editing /etc/mydns.conf I see the values are default, so I change them:
    ##  /etc/mydns.conf
    ##  Fri Sep 21 21:44:51 2007
    ##  For more information, see mydns.conf(5).
                                    # DATABASE INFORMATION
    db-host = localhost             # SQL server hostname
    db-user = root                  # SQL server username
    db-password = XXXXX    # SQL server password
    database = dbispconfig                  # MyDNS database name
    Now it connects, however, that database doesn't seem to contain the correct tables needed for MyDNS.

    Did I miss something?
  2. tristanlee85

    tristanlee85 New Member

    From what I've read, ISPConfig 3 does not support BIND yet the interface mentiones BIND in the Server Configuration section along with
    when I install.

    This is odd. I followed exactly the steps in the Perfect Server setup for Fedora 12.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if you had bind and mydns package installed which confused the installer. Please remove bind with yum and run the ispconfig update again.
  4. tristanlee85

    tristanlee85 New Member

    Thanks for the reply. I will give that a shot later.
  5. ciscokid

    ciscokid New Member

    I had the same problem

    Thanks tristanlee85 for starting the thread and till for your solution!

    I had exactly the same issue with Centos 5.4 (32bit) install with ISPConfig 3 and had followed exactly the same setup as for the 64bit 5.4 and 32 bit 5.2.

    I unistalled bind using yum and uninstalled ISPConfig and re-installed it rather than doing the update (which I'm sure would have worked anyway).

    The problem I am still getting (and I'm sure this is only an CentOs issue) is a dovecot issue

    I dont mean to hijack your thread tristanlee85

  6. ciscokid

    ciscokid New Member

    Looking at the dovecot.conf file, this is waht I see

  7. tristanlee85

    tristanlee85 New Member

    Hey no problem. I also made a thread about the Dovecot issue. What I did was uninstalled bind and dovecot :

    yum remove bind dovecot
    And then ran:

    php -q update.php
    And it configured for Courier and MyDNS, and I not longer got the dovecot errors like you and I previously got.

    I don't know if the tutorial installs bind and dovecot, or if it was a default package installed. I think it might be worth making a note in the tutorial (if it isn't already there; I didn't see one) to uninstall bind and dovecot for a ISPConfig 3 server since it doesn't seem to support those services.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ispconfig supports bind and dovecot starting from 3.0.2, but as you initially installed your systems with, you use courier and mydns instaed (which gives you basically the same functionality then bind and dovecot) and in this case, dovecot and bind should not be installed. The perfect setup tutorial does not mention it yet as it has not been updated for ispconfig 3.0.2 yet.
  9. tristanlee85

    tristanlee85 New Member

    Ahh. I did find it odd that in previous posts I saw where bind wasn't supported, yet in the interface there was a section specifically labeled for bind. Either way, I got it working with MyDNS and Courier so I think I am happy. Thanks for the help!
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Just as reference for readers of this post: the latest install instructions for Centos 5.4 and Fedora 12 with Bind and Dovecot are available as txt files in the docs folder of the ispconfig 3.0.2 tar.gz file.
  11. ciscokid

    ciscokid New Member

    Cheers tristanlee85 and till - I must admit I thought why we have both dovecot and courier, so uninstalled dovecot and updated it again as per your post.
    Thanks again guys.
  12. falko

    falko Super Moderator ISPConfig Developer

    I've just updated the "Perfect Server" tutorials for CentOS and Fedora. :)

Share This Page