MyDNS startup failed

Discussion in 'General' started by gcambull, Feb 22, 2009.

  1. gcambull

    gcambull New Member

    during the initial ISPConfig install the failure of MyDNS to start up was present, I put it aside for a couple weeks, as I had other projects. Now that I have the time, I booted the server and the same failure occurs with MyDNS connecting to Mysql, here is the error after I used the Interactive startup:

    Start Service MyDNS: [Y]es/[N]o/[C]ontinue
    Starting MyDNS: mydns[2347]: error connecting to Mysql Server at localhost: Can't connect to local Mysql Server through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)      [FAILED]
    FYI Mysql start up comes after Mydns, could that be a factor and how to correct it.

  2. falko

    falko Super Moderator ISPConfig Developer

    /etc/init.d/mydns restart
    Does it start then?
    Which distribution are you using?
  3. gcambull

    gcambull New Member


    After searching for other answers I came across one of the same question but in the ISPconfig cat, and saw that you asked the same question. And yes it did restart, first it failed on stopping then it said start was ok. I was also curious why it stated it was failing on startup, but ISPConifg stated it was working.

    Answer is yes.


    Using CentOs5.2
    Last edited: Feb 23, 2009
  4. binaryrogue

    binaryrogue Member

    I'm also experiencing the same issue. ONLY During startup, myDNS would not start. If I restart services as mentioned, it will start fine.. I'm using Fedora 9.

    Mar 2 08:57:35 ispc1 mydns[1890]: Error connecting to MySQL server at localhost: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)

    After doing a "service mydns restart"

    Mar 2 09:08:01 ispc1 mydns[2648]: mydns 1.1.0 started Mon Mar 2 09:08:01 2009 (listening on 3 addresses)
    Last edited: Mar 3, 2009
  5. binaryrogue

    binaryrogue Member

    mydns does appears to start before mysql. I just changed the startup order around in the rc3.d/ directory.
  6. gcambull

    gcambull New Member

    ...and how do you do that? The problem I had went away, but like someone also said, wait and it will begin to play (so to speak), but how do you change the order?


    oh wait ur using Fed 9, me using CentOs5.2, hmm
    Last edited: Mar 3, 2009
  7. binaryrogue

    binaryrogue Member

    The /etc/rc.d/rc3.d/ directory list all services that starts up on run level 3. I changed the order by giving mysqld a higher priority.

    Before the change -

    After the change -
  8. baskin

    baskin Member

    I have the same problem on Opensuse 11.1.

    Mydns fails on startup but it runs ok if i execute it after the boot.

    The strange with me is that in my /etc/rc.d/rc3.d i have:


    but it fails to load on boot.

    Any suggestions?
  9. nikita

    nikita New Member

    Exact same problem here. I even tried installing on defferent machines(4) and... same problem. I've also change the name to S99mydns to be sure, but no effect. tried to edit the /etc/rc.d/rc3.d/S11mydns to put a dependency to start after mysql... no luck. All-in-all i've spent 5 days trying to find a solution. Any help from some openSUSE gurus?
  10. falko

    falko Super Moderator ISPConfig Developer

    I'd try to change S11mydns to S99mydns.
  11. nikita

    nikita New Member

    Heh, tried that already :). Any other ideas?
  12. 40esp

    40esp New Member

    For the SuSE users, here is a fix:

    Put your services in order under rc3.d.

    Edit this file: /etc/sysconfig/boot

    vi /etc/sysconfig/boot

    and set: RUN_PARALLEL to "no".

    Fixed if for me :)
  13. baskin

    baskin Member

    That also fix the problem for me as well.

  14. matiasCU

    matiasCU Member

    Solved on Debian installation

    In a debian installation, just simply change the value of runlevels, eg if we have: /etc/rc3.d/S19mysql and /etc/rc3.d/S19mydns should be changed to make sure the value of mydns by S99mydns and in the rest of the runlevels rc0.d, rc1.d, rc2.d

    That's all, we can try restarting the server

Share This Page