Mysql Error message after driver is replaced with mysqlnd

Discussion in 'Server Operation' started by NginxHolic, Jun 17, 2015.

  1. NginxHolic

    NginxHolic New Member


    I am using Debian 7.8 ISPConfig latest version
    DotDeb Repo.

    Somehow, I replace the MYSQL driver with MYSQLND. After that, whenever I install something, it will output:
    Setting up php5-mysqlnd (5.4.41-1~dotdeb+7.1) ...
    ERROR: mysql module symlink already exists in /etc/php5/conf.d with different content
    dpkg: error processing php5-mysqlnd (--configure):
    subprocess installed post-installation script returned error exit status 1
    Processing triggers for php5-fpm ...
    [ ok ] Restarting PHP5 FastCGI Process Manager: php5-fpm.
    Errors were encountered while processing:
    How to fix this, I'm afraid I will mess the whole installation.

    Thank you

  2. I would suggest to remove the pdo file and re-install php5-mysqlnd first.
    • Backup /var/lib/dpkg/status just to be sure with a command like
      cp /var/lib/dpkg/status /var/lib/dpkg/status.backup
    • Delete all entries to php5-mysqlnd in /var/lib/dpkg/status with a text editor like nano or vi.
    • Backup and remove the current pdo with
      sudo mv /etc/php5/conf.d/10-pdo.ini /etc/php5/conf.d/10-pdo.ini.backup
    After that
    apt-get install php5-mysqlnd
    installation should install php5-mysqlnd and then you should be able to use
    apt-get -f install
    without problems.
  3. NginxHolic

    NginxHolic New Member

    Hello, thank you for answeing this.
    I tried to follow the steps, but the second guide confuses me.
    How to know which one should be deleted?
    Then, I tried to continue the process and the process still occurs.

    EDIT: Now some applications can't connect to mysql. It says error can't connect to PDO, thus I have reverted the configuration back to initial condition.
    Mysql still show errors.
    Last edited: Jun 21, 2015
  4. NginxHolic

    NginxHolic New Member

    Anyone, this issue has not been resolved.
    I think this problem is causing slow page load on some mysql sites of mine.

Share This Page