Mysql Error

Discussion in 'General' started by Maile Halatuituia, May 3, 2017.

  1. After i upgrade twice my panel from ubuntu 12 to Ubuntu 14 then to Ubuntu 16 using do-release-upgrade.
    I have this error when is try to add a new emailbox on my panel

    #0 db->query(INSERT INTO `mail_user` (`server_id`, `email`, `login`, `password`, `name`, `quota`, `cc`, `maildir`, `homedir`, `uid`, `gid`, `postfix`, `disablesmtp`, `disableimap`, `disablepop3`, `sys_userid`, `sys_groupid`, `sys_perm_user`, `sys_perm_group`, `sys_perm_other`) VALUES ('33', '[email protected]', '[email protected]', '$1$gfJan/Po$2F1BZcKN4cnQ20zOi99ir0', 'Vavau', '0', '', '/var/virtual/', '/var/virtual', '5000', '5000', 'y', 'n', 'n', 'n', '1', '1', 'riud', 'riud', '')) called at [/usr/local/ispconfig/interface/lib/classes/] #1 tform_actions->onInsertSave(INSERT INTO `mail_user` (`server_id`, `email`, `login`, `password`, `name`, `quota`, `cc`, `maildir`, `homedir`, `uid`, `gid`, `postfix`, `disablesmtp`, `disableimap`, `disablepop3`, `sys_userid`, `sys_groupid`, `sys_perm_user`, `sys_perm_group`, `sys_perm_other`) VALUES ('33', '[email protected]', '[email protected]', '$1$gfJan/Po$2F1BZcKN4cnQ20zOi99ir0', 'Vavau', '0', '', '/var/virtual/', '/var/virtual', '5000', '5000', 'y', 'n', 'n', 'n', '1', '1', 'riud', 'riud', '')) called at [/usr/local/ispconfig/interface/lib/classes/] #2 tform_actions->onInsert() called at [/usr/local/ispconfig/interface/lib/classes/] #3 tform_actions->onSubmit() called at [/usr/local/ispconfig/interface/web/mail/mail_user_edit.php:230] #4 page_action->onSubmit() called at [/usr/local/ispconfig/interface/lib/classes/] #5 tform_actions->onLoad() called at
    [/usr/local/ispconfig/interface/web/mail/mail_user_edit.php:328] Incorrect datetime value: '0000-00-00 00:00:00' for column 'autoresponder_start_date' at row 1

    Anyone with a hint would very much appreciate.
    Note :
    I dont have any error on ispconfig log , this is print on the page load with bunch of other lines as wel ..
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you update ISPConfig to 3.1.2 already? If not, update it. Or has this value be set e.g. by roundcube, in that case, you will have to update the roundcube ispconfig plugin.
  3. ok great .. to upgrade i have to upgrate the panel first then upgrade all my clients or clients first then my panel to the latest version ???
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The master server first and then the slave servers. The update is necessary because MySQL dropped support for the value '0000-00-00 00:00:00' as 'not set' in datetime fields, instead the new MySQL version that you have installed now requires NULL in that field, and that's what ISPConfig since 3.1 is using.
  5. ok will do that now .. thanks for the info though ... will let you how it result afterwards. ..thanks any way
  6. After starting the update i got this error
    PHP Fatal error: Class 'mysqli' not found in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 31
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that the PHP on your server has mysqli support by installing the php mysqli package.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Btw, there is also a way to stay at the old ispconfig version if you prefer that, you will have to configure mysql to be less strict then so that it is compatible with older mysql versions.
  9. ok how to do that ???
  10. Now i have run the update with no issue but i cant login to panel admin afterwards.
    any hint
  11. After upgrading my dns client i have ths warning as well
    WARNING - Falsche Anfrage / Wrong QuerySQL-Query = REPLACE INTO `dns_rr` (`id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`zone`,`name`,`type`,`data`,`aux`,`ttl`,`active`,`stamp`,`serial`) VALUES ('7572','69','69','riud','riud','',39,'219','','MX','','10','172800','Y','2014-10-03 21:59:06','2016090101') -> 2006 (MySQL server has gone away)
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    The SQL error means that MySQL was offline at the time the query was run.

    Regarding login: empty the browser cache and delete all cookies related to the server URL in your browser.
  13. Yes Till
    Both my issue now is fixed.
    1. For mysql error is reboot my server and all is back to normal.
    2. I delete cookie and reload my browser and all good now.
    Thank you so much for your support.
  14. Now one of my webser got this
    Checking ISPConfig database .. OK
    Unable to read server configuration from database
    when run update
  15. now i manage to fix my upgrade with correcting server_id and server_name on my client server table. but i run in to this error .. i think it is to do with my php below when start apache2 afterwards but if you have any lead please let me know

    Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

  16. Mike007

    Mike007 New Member

    I got the same error due to upgrade mysql server from 5.6 to 5.7; ISPConfig ver., CentOS 6.10
    You can check your current strick mode:
    # mysql -u root -p -e "SHOW VARIABLES LIKE 'sql_mode';"
    Eg. output contains NO_ZERO_IN_DATE and NO_ZERO_DATE which causes this problem.
    | Variable_name | Value                                                                                                                                     |
    then edit /etc/my.cnf and put this code:
    Restart your mysql server.

Share This Page