MySQL installation roblem [/me sad]

Discussion in 'Installation/Configuration' started by Nejko, Jan 9, 2006.

  1. Nejko

    Nejko New Member

    Hey all!

    First i would like to say huge thnx to all developers of ISPConfig!

    Now my little problem :)

    I'm runnin' FC4 (fedora core 4) wit xampp. I download ispconfig, unrar it, go to shell and write ./setup . It asks me couple questions... etc etc, everything ok, till it comes to mysql chech. I have definly installed mysq on my server, it's just that ISPConfig installation do not recognize it. It gie this error:

    ########## MYSQL SERVER ##########

    Checking for package MySQL...
    which: no mysql in
    ERROR: mysql not found!
    [root@localhost kontrola]#

    I guess problem is in the file which checks for mysql. It is searching dir's where default(spelling? :S)


    My mysql is in /opt/lampp/etc...

    Where can i fix my problem?

    Thanx for all your answers!

  2. falko

    falko Super Moderator Howtoforge Staff

    The problem is that you have a non-standard installation.

    You can try to create a symlink to your mysql binary like this:

    ln -s /path/to/mysql /usr/bin/mysql
    I don't know if this helps. I'd recommend that you have a look at this tutorial:
  3. Nejko

    Nejko New Member

    Hey, tnx for reply!

    But i don't know what u mean with that symlink :) i'm quite a newbie to whole linux scene, so i raither installed xampp, which does all the dirty work. Can u be plz more specific about symlink stuff?

    Keep up good work! ;)

    edit: i don't work :(
    Last edited: Jan 9, 2006
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem with packages like xampp is, that they install linux applications in uncommon places. It might be that you encounter other errors later.

    The best way to install ISPConfig is to follow one of the howtos on howtoforge that prepare your linux server for ISPConfig. They where written as copy and paste howtos so that even beginners can follow them easily.

    To your problem with the symlink, if i understand the xampp docs right, the symlink must be:

    ln -s /opt/lampp/bin/mysql /usr/bin/mysql
    But its untested because i dont have xampp installed.
  5. Nejko

    Nejko New Member

    i did it as u said, but still not working :(
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig has been never tested with xampp. I recommend that you setup your server again with one of the howtos. You can find a list at the bottom of this page:

    Someone who is really familar with linux might get xampp to work with ISPCOnfig, but for beginners the howtos are the better and easier way.
  7. Nejko

    Nejko New Member

    so there's no way to get this working? :( cuz everything now worrks ok, so don't wan't to reinstall :( :confused:
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    How did you know that everything works ok with ISPConfig or will be at least working with ISPConfig at all before you got ISPConfig installed? The problematic part is in most cases the postfix setup, not mySQL and apache. And the paths to all config files are incorrect when you install the files with xampp so you will have to tweak the ISPConfig settings to get everything to work properly.
  9. Nejko

    Nejko New Member

    hmm, is there any file, where can i change where to look for mysql? :)
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    install_isconfig/setup and install_isconfig/setup2
  11. falko

    falko Super Moderator Howtoforge Staff

  12. Nejko

    Nejko New Member

    well, in toturial i can't get apt install ;) cuz i have amd 64bit :) (apt version is 32...) also mysql problem.. well, i found that in setup2:

    export PATH="/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec"

    i'll try to add my folder in here :)
  13. Nejko

    Nejko New Member

    ########## INSTALLATION ##########

    ERROR: Could not find mysql.sock! The installation routine stops here!
    [root@localhost control]#

    it's making some progress now :D any ideas for that? :D
    Last edited: Jan 10, 2006
  14. falko

    falko Super Moderator Howtoforge Staff

    You can use yum instead. The syntax is exactly the same:
    yum install <package>
    instead of
    apt-get install <package>
  15. Nejko

    Nejko New Member

    yeah, got that :) any suggestions to my post above?
  16. falko

    falko Super Moderator Howtoforge Staff

    That's because your MySQL is installed in a non-standard location (because you installed XAMPP).
  17. Nejko

    Nejko New Member


    Last edited: Jan 11, 2006

Share This Page