Mysql on openSUSE 11.2 (i586)

Discussion in 'Installation/Configuration' started by Gert-jan, Jul 15, 2010.

  1. Gert-jan

    Gert-jan New Member

    Hi there,

    I've a question:

    I've installed Mysql (with YAST), but when i now want to start mysql i get an error:

    Restarting service MySQL
    Shutting down service MySQL done
    Will update MySQL now, if you encounter any problems, please read following file:
    Running protected MySQL...
    error: /var/run/mysql/protected/mysql.sock file didn't appeared...

    I tried a lot but i don't know what to do now.
    Can anyone help me?


  2. Mark_NL

    Mark_NL Member

    Is this mysql an upgrade or a fresh installation?
  3. Gert-jan

    Gert-jan New Member

    Mysql was already on that server and it worked.

    but with some problems with the database, we've desided to remove mysql and reinstall it.......
    And now it won't work......:mad:
  4. Mark_NL

    Mark_NL Member

    Hmm make sure mysql is REALLY removed, don't upgrade OVER the old one, remove the old one first, then install the new version. should do the trick..

    i'm reading a lot of threads and it always comes down to ppl who upgrade over the old one, instead of removing it first.

    i assume the dir /var/run/mysql/protected/ exists?

    what's the mysql socket location defined in your my.cnf?
  5. Gert-jan

    Gert-jan New Member

    Hi Mark,

    First of all, thans for taking some time for me!

    I've looked, and the dir /var/run/mysql/protected/ exists!
    (It's an empty dir)

    a part of the my.cnf (/etc/my.cnf):
    #password = your_password
    port = 3306
    socket = /var/run/mysql/protected/mysql.sock

    # Here follows entries for some specific programs

    # The MySQL server
    port = 3306
    socket = /var/run/mysql/protected/mysql.sock
    key_buffer_size = 16K
    max_allowed_packet = 1M
    table_open_cache = 4
    sort_buffer_size = 64K
    read_buffer_size = 256K
    read_rnd_buffer_size = 256K
    net_buffer_length = 2K
    thread_stack = 128K

    I re-installed mysql with yast.

    First removed mysql and mysql client with yast, then rebooted the server, and then reinstalled mysql with yast.....
  6. Mark_NL

    Mark_NL Member

    What user runs the mysqld process? is that user allowed to write in /var/run/mysql/protected ?

    ps flax | grep mysql
    grep mysql /etc/passwd
    ls -al /var/run/mysql/protected

Share This Page