Need help in configuring FC4 for installing Oracle DB 10g.

Discussion in 'Installation/Configuration' started by victagious, Nov 14, 2005.

  1. victagious

    victagious New Member

    I am new to Linux FC4 and Oracle DB 10g. I am installing Oracle DB 10g on my already installed Fedora Core 4 (Everything).

    I am trying to complete the pre-installation steps for Oracle DB. I need help with the issue of installing lower versioned FC4 packages when higher versioned packages are already installed. I ran the command:

    # rpm -q compat-gcc-7.3
    Output: package compat-gcc-7.3 is not installed.

    # rpm -q compat-gcc
    Output: compat-gcc-

    What I understand is the following:
    I have the compat-gcc package but it is the version.

    But I need the 7.3 version for the correct installation of the Oracle DB 10g.

    When I try to install the compat-gcc version from the '' site, I get the message that, "a newer version is installed". So, the OS doesnt accept the 7.3 version.

    How do I install the compat-gcc-7.3 versioned package?

    Do I need to uninstall the whole thing and reinstall the whole thing? That
    sounds easier and faster rather than wasting time with this workaround.

    thanx in advance,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to uninstall compat-gcc- before you can install the 7.x version.
  3. victagious

    victagious New Member

    Thanx Till. I will do that once I get home today.

    Thanx again,
  4. victagious

    victagious New Member

    Uninstall is good. But where do I install the package?

    Hi Till,

    Based on what you said, I was able to uninstall the higher version. I downloaded the required gcc package and saved it on my desktop. I tried to run (install) it directly, but got some error message. So, I downloaded the package and saved it to my desktop.

    Then, when I installed the package - I had 365 items put on my desktop. :) So, what do I do now? Can I just cut them and paste them in some folder? If so, which folder? I am not familiar with the Linux directory structure; as to which folder is meant for what functions.

    Thanx again, in advance.

  5. falko

    falko Super Moderator Howtoforge Staff

    You can put the package in any folder you like on your Linux system. then go to that folder on the command line and install the package:

    cd /path/to/folder
    rpm -ivh <package>.rpm
  6. victagious

    victagious New Member

    sounds good.

    thanx falko.
  7. victagious

    victagious New Member

    a lil problem now...

    Hi again,

    Since I had a lot of items on my desktop, I uninstalled compat-gcc hoping that would eliminate and remove all the patches from my desktop.

    That did not happen. compat-gcc got removed from my system, but the patches were still left on my desktop.

    I manually deleted the files to trash.

    Then I moved the compat-gcc src.rpm to a different folder in my desktop and tried to install the package using yum. I got :

    [root@localhost rpm]# yum install compat-gcc-7.3-2.96.128.src.rpm
    Setting up Install Process
    Setting up repositories
    updates-released 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    base 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    Parsing package install arguments
    Cannot open file: compat-gcc-7.3-2.96.128.src.rpm. Skipping.
    Nothing to do
    [root@localhost rpm]#

    (1) why is it skipping the file... the file is present there.
    (2) also, where can I find other packages? My up2date has a problem - it wont work for some reason.

  8. victagious

    victagious New Member

    I was able to install the package... but the second question still persists.

    where do I find new pacakges but not have them install automatically?

  9. falko

    falko Super Moderator Howtoforge Staff

    compat-gcc-7.3-2.96.128.src.rpm is a source rpm, not a binary rpm. Source rpms still have to be compiled, I don't think this is what you want. You should search for a binary package.
  10. victagious

    victagious New Member

    u are right.

    Hi Falko,

    I had installed the 64 version file.

    Thank u all for all ur help.

  11. victagious

    victagious New Member

    Need some serious help.

    Hi again,

    This time, I have another issue.
    I inserted the FC4 disk3 and ran the following command:
    # rpm -Uvh compat-libstdc++-33-3.2.3-47.fc4.i386.rpm
    warning: compat-libstdc++-33-3.2.3-47.fc4.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
    compat-libstdc++ = 7.3-2.96.128 is needed by (installed) compat-libstdc++-devel-7.3-2.96.128.i386
    compat-libstdc++ = 7.3 is needed by (installed) compat-gcc-c++-7.3-2.96.128.i386

    Then I tried to diagnose the scenario:
    [root@localhost ~]# rpm -q compat-libstdc++

    [root@localhost ~]# rpm -q compat-libstdc++-devel

    [root@localhost ~]# rpm -q compat-gcc

    Everthing is present. Why am I still receiving the above error?

    Finally, I thought of giving it another try. So, I am removing the compat-libstdc++ package.
    I will try the installation again.

    [root@localhost ~]# yum remove compat-libstdc++
    Setting up Remove Process
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package compat-libstdc++.i386 0:7.3-2.96.128 set to be erased
    --> Running transaction check
    Setting up repositories
    updates-released 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    base 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    --> Processing Dependency: compat-libstdc++ = 7.3 for package: compat-gcc-c++--> Processing Dependency: compat-libstdc++ = 7.3-2.96.128 for package: compat-libstdc++-devel
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package compat-libstdc++-devel.i386 0:7.3-2.96.128 set to be erased---> Package compat-gcc-c++.i386 0:7.3-2.96.128 set to be erased
    --> Running transaction check

    Dependencies Resolved

    ============================================================================= Package Arch Version Repository Size
    compat-libstdc++ i386 7.3-2.96.128 installed 3.7 M
    Removing for dependencies:
    compat-gcc-c++ i386 7.3-2.96.128 installed 4.7 M
    compat-libstdc++-devel i386 7.3-2.96.128 installed 1.6 M

    Transaction Summary
    =============================================================================Install 0 Package(s)
    Update 0 Package(s)
    Remove 3 Package(s)
    Total download size: 0
    Is this ok [y/N]: y
    Downloading Packages:
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Removing : compat-libstdc++-devel ######################### [1/3]
    Removing : compat-libstdc++ ######################### [2/3]
    Removing : compat-gcc-c++ ######################### [3/3]

    Removed: compat-libstdc++.i386 0:7.3-2.96.128
    Dependency Removed: compat-gcc-c++.i386 0:7.3-2.96.128 compat-libstdc++-devel.i386 0:7.3-2.96.128

    [root@localhost ~]# rpm -q compat-gcc

    [root@localhost ~]# rpm -q compat-gcc-c++
    package compat-gcc-c++ is not installed

    [root@localhost ~]# rpm -q compat-libstdc++
    package compat-libstdc++ is not installed

    [root@localhost ~]# rpm -q compat-libstdc++-devel
    package compat-libstdc++-devel is not installed

    If anyone can figure this out... plz let me know.
    By the way, I downloaded the packages from:

  12. victagious

    victagious New Member

    this is what someone told me.

    I was told by a colleague that I basically installed the 7.3-2.96.128 version. Then, I ran the # rpm -Uvh compat-libstdc++-33-3.2.3-47.fc4.i386.rpm, which is technically updating the file. The depedencies got deleted along with that file and then I would reinstall the higher version.
    I should have used # rpm -Uvh compat-libstdc++-33-3.2.3-47.fc4.i386.rpm

    My mistake again.
    Learning one day at a time.


Share This Page