netpbm installation on suse 10.0

Discussion in 'Technical' started by nox171, Apr 20, 2007.

  1. nox171

    nox171 New Member

    Hi all,

    I'm trying to install netpbm on my susebox.
    I did it using yast but an oscommerce module link

    this is the output:
    server1:/tmp # rpm --query --all | grep -i netpbm
    server1:/tmp #
    then I presume it is installed. Isn't it?

    But the contribution module seems not to work. It is creating a link to a image that doesn't exist. The link is something like nameofthephoto_5-x80.jpg but the image is not in place.

    Does anyone have any suggestion?
    Last edited: Apr 20, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    Yes, it is installed.

    Maybe you have to restart some services such as Apache or (maybe easier) even the whole server.
    Does nameofthephoto_5-x80.jpg exist somewhere on the server?
  3. nox171

    nox171 New Member

    now I'm trying everything on a backup server so I did a restart and something seems to be changed.
    Now I have inside the /images folder the file but it's with no size.
    I have:
    nameofthephoto_test-80x80.jpg and the size is 0 Kb.

    Probably there is something wrong on the add on.
    In the install file inside the contribution there is something concerning NetPbm-progs (programs..).
    I didn't find anything to install them, maybe I'm missing something. Or they are inside the NetPmb program!?

  4. falko

    falko Super Moderator ISPConfig Developer

    What does the file say?
  5. nox171

    nox171 New Member

    this is the file:
    INSTALL img_resample
     You need:
      Linux or some other *nix
      download and install NetPBM and NetPBM-progs. they're on
      gunzip and untar the img_resample.tar.gz -file
      (it should be in the /catalog/includes/functions folder and be named image_resample.php)
      open your html_output.php (in the same folder as you put resample.php)
      go to approx line no 73 which is something like this:
    // The HTML image wrapper function
      function tep_image($src, $alt = '', $width = '', $height = '', $params = '') {
        if ( (($src == '') || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) {
          return '';
     -AFTER- these lines you add:
        if ( ($width == SMALL_IMAGE_WIDTH && $height == SMALL_IMAGE_HEIGHT) || $resample ) {
        	include DIR_FS_CATALOG . "/" . DIR_WS_FUNCTIONS . "image_resample.php"; 
    (three lines of code)
    Now it should work if your netpbm programs are installed correctly
    I tried also to install another contributor, it is newer and better I think: 'on the fly'.
    Here happened something really odd!
    I have two server, live one and backup one.
    They have preatty much the same installation of suse 10.1 with ispconfig.
    In the backup server this new module works fine, in the live server basically I don't see the images if it is turned on!
    Do you know where I can look to find the problem source?

  6. falko

    falko Super Moderator ISPConfig Developer

  7. nox171

    nox171 New Member

    Yes I did but I preferred to do the installation from yast.
  8. nox171

    nox171 New Member

    I fixed it. I had selected in ISPConfig the php safe mode.

    At the end anyway I didn't install the Netpbm contributor but the last one that i mentioned.

    Thanks to all!

Share This Page