New Installation Error!!

Discussion in 'Installation/Configuration' started by cybereatl, Feb 11, 2006.

  1. cybereatl

    cybereatl Member

    Hi there, after finally have done Perfect Instalation of FC4 with Falko's help am installing ISPConfig, I did good until I got this: see file

    I've check yum search php-bison

    Tells me that install flex, bison and bison-devel should I proceed and install thoses???

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes please install flex.

    apt-get install flex

    You can install bison and bison devel too. I think its not nescessary but it dont hurts on the other hand :)

    apt-get install bison bison-devel
  3. cybereatl

    cybereatl Member

    Thanks for reply I have installed packages missing and now good to go, I did install ./setup and everything works ok until here:
    Please enter your MySQL server: E.G. localhost
    Please enter your MySQL user: E.G. root
    Please enter your MySQL password: xxxxxx
    Please enter a name for the ISPConfig database: E.g. ispconfigdb
    Please enter the IP address of the ISPConfig web: E.g.
    Please enter the host name: E.g. www
    Please enter the domain: E.g.
    ERROR: The URL is not reachable! The installation routine stops here!

    Not sure at this point, has to be a free domain?? is a running domain and site, must be another one??
    What should I do? use another domain?? if so ISPconfig allows me to set my name servers ns1 and ns1 to tell domain that reach that IP address??
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The installer tries to ping, if the ping fails, the installer will stop.

    Either use the host / domain of your server or leave the host field empty and enter your Server IP when you where asked for the domain.

    Dont forget to delete /root/ispconfig, /home/admispconfig and install_ispconfig before you run the installer again. Also the mysql database must be deleted, if it was created by the installer.
  5. cybereatl

    cybereatl Member

    Thanks for reply!! Am gonna use my server name I was able to remove folder but not sure how to remove databases using mysqladmin drop ispconfigdb!! I have not installed phpmyadmin so from myslq there is no option to remove, only with mysqladmin but as well not sure how to.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Have a look in the directory:


    If there is a directory with the name that you chose for the ISPConfig database, just delete this directory.
  7. falko

    falko Super Moderator Howtoforge Staff

    You can also do it like that (you should try this first):

    mysql -u root -p
    Enter password:
    DROP DATABASE ispconfigdb;
  8. cybereatl

    cybereatl Member

    Thank you guy for the help.
    I was in about to drop database but it wasn't there anyway, I try runnig install again and I got:
    All prerequisites are fulfilled.
    Here we go...
    Please enter your MySQL server:localhost
    Please enter your MySQL user:root
    Please enter your MySQL password:
    Please enter a name for the ISPConfig database (e.g. db_ispconfig):ispconfigdb
    Please enter the IP address of the ISPConfig web (e.g.
    Please enter the host name (e.g. www):www
    Please enter the domain (e.g.
    ERROR: The URL is not reachable! The installation routine stops here!
    [root@morticia install_ispconfig]#

    Still giving me the error for domain and I have tried machine name: but as well kick me out of installation!!!

    Any suggestions???
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    I wrote:

    and you entered www as host. Leave the host field empty means enter nothing, because "www." is not a valid URL.
  10. cybereatl

    cybereatl Member

    Hey Till,

    It works ok, now I was able to finish up instalation, am reading documentation to host my first site, not sure how work setting domain name to ISPConfig box, but so far am trying reading!!
  11. cybereatl

    cybereatl Member

    Instalation went Ok, now setting up a web site!

    Hi there,
    finally ISPConfig is up and running now my question, I want to add a site.
    I have created a reseller, then a package and finally a site.

    Still not clear settings for domain to be added nameserver to godaddy domain? it request format and

    How do I set properly a site, normally using Cpanel I create a reseller, then a package and create and account, previously there it was a domain who was oficially registered to be pointed to 2 static ip's that and was requesting.

    Please advise.
    Thanks a lot
  12. falko

    falko Super Moderator Howtoforge Staff

  13. cybereatl

    cybereatl Member

    Ok, thanks i'll go ahead and do that iwth Godaddy.
    Now I was trying to create a site as user and after create packages went to create a site and I got:

    The following error occurred:

    You have left only 20 user(s) which you can assign to this website.

    Next >> and I click in and got:


    Sites used: 0 of 20
    Diskspace used: 0 MB of 50000 MB
    Users used: 0 of 20
    Domains used: 0 of 30
    Master Zones created: 0 of 20
    Slave Zones created: 0 of 20
    Databases created: 0 of 100

    Also when creating a site should I check:
    Create DNS: and Create DNS-MX or just leave it alone, also when mention Max. Users it refers to simultaneously connection?

  14. till

    till Super Moderator Staff Member ISPConfig Developer

    If you want to get DNS-Records for a domain automatically in ISPCOnfig DNS-Manager, you must check the create DNS and create DNS-MX checkboxes.

    Max. Users means the number of email users that you can create in this website.
  15. falko

    falko Super Moderator Howtoforge Staff

    Can you try again? Does it then happen again?
    I think this happens because of the table definition of the reseller MySQL table. This has already been fixed in the SVN version and will be available with the next ISPConfig release.

    You don't need these as you're using godaddy for managing your DNS records.
  16. cybereatl

    cybereatl Member

    Well, it seems to be an issues with the reseller account but I went to admin and I was able to create a site.

    I have registered and with two different public ip's and then change domain with the new registered nameservers!!!

    Now am waiting to site propagation and see what happens!!!! If some one can look at it if is working

    Here is a question: I got and odd issue with my site, I got a cpanel temporary license and I can't see my sites on my office, there is no firewall configured, only Norton Internet Seciruty 2005 on my machine, I turned off and just can't see my site: I know that from US they can see it, even from my home I can see it, just don't know what is going on!!! even I got a 4 port wireless router with next IP server is .206 and .205 router is .203 but just can see it, but if I enter with the ip take me to other site.

    Thanks for any tips!!
    Last edited: Feb 18, 2006
  17. falko

    falko Super Moderator Howtoforge Staff

    Maybe you must use other DNS servers in your office/on your office computer.
  18. cybereatl

    cybereatl Member

    I got a problem with the DNS's because all ip addresses that I got use the same, we got a 512 dedicated service and for all IP's is same dns and gateway!!

    I was looking on godaddy DNS Manager and went to add A and MX record.

    I add as A record to:
    www 1hour
    @ 1hour

    What should I add to MX Record??

    priority Host Goes to TTL
    0 @ 3600 3600
    10 @ 3600

    Don't know what to do!! When I setup Cpanel server, they said that I can use even the .info domain, just need to change something on apache file, but they did it remotely, I was wondering can I do that too, just to don't loose my .info domain??
    Last edited: Feb 20, 2006

Share This Page