New ISPConfig Install

Discussion in 'Installation/Configuration' started by nubtool, May 10, 2006.

  1. nubtool

    nubtool New Member

    Hi all, Great site BTW.

    I have been looking around here the last couple days and i have just completed a new install of Fedora 5. I followed the The Perfect Setup from Falko and it went well. I didnt install the Mail portion because i dont require that at this time [read didnt feel like it]. :)

    Im following this install guide for ISPConfig:

    Important: ISPConfig is meant to be installed on new Linux installations with no web sites, so if you run a server with hundreds of web sites and need a control panel that can take care of those existing web sites, then ISPConfig is not for you!

    Log in to your shell as root.
    Unpack the ISPConfig-archive

    tar xvfz ISPConfig*.tar.gz

    and change to the directory install_ispconfig:

    cd install_ispconfig

    In this directory please check the file dist.txt and see if the values given there suit to your
    Linux installation (they should be suitable for standard installations). If you change any
    values please be sure not to change the format of the file.
    Then start the setup-script from there:


    The installer will now compile an Apache with PHP5 that will run on port 81 and is needed by the ISPConfig system itself. It will not interfere with your existing Apache installation so you can go on unworried.

    Important: Be sure to have installed gcc, flex and all the other tools neded for compiling sources before you run ./setup! You also need to install the MySQL header files which normally come in a package called mysql-devel, mysql-dev, libmysql-devel or something similar. Otherwise PHP5 will not compile, and the installation of ISPConfig stops!

    Onto the Question:

    I have logged onto the Terminal as root and tried running the install. But i was using "yum" thruought the HOW TO. How do start the install with yum? How do i install GCC and FLEX?

    Yes im a nub [read newb]. :D

    Thanks for your help in advance.
  2. falko

    falko Super Moderator Howtoforge Staff

    If you've followed the tutorial to the letter, gcc and flex are already installed (if they aren't, the ISPConfig installer will tell you... ;) ).
    You don't need yum to install ISPConfig.
    This is what you do:
    cd /tmp
    tar xvfz ISPConfig-2.2.2.tar.gz
    cd install_ispconfig
  3. nubtool

    nubtool New Member


    My test laptop is at work so i will post back with an update tomorrow. Thanks!
  4. nubtool

    nubtool New Member

    Well so far so good!

    I am now being asked: PLease enter your MySQL server name:

    Is this the name of my machine? The IP address?

    Not sure what to input here. Please forgive my ignorance, its my first dive into the Linux world. Also, i cant find /home/www...


    Last edited: May 11, 2006
  5. falko

    falko Super Moderator Howtoforge Staff

    Enter localhost

    This directory will be created by ISPConfig automatically.
  6. nubtool

    nubtool New Member

    OK i have passed the install. :cool:

    1. Cant logon with default username/password [admin,admin] with ISPConfig.
    2. I can view my ISPConfig default website from within my network, but not from outside. I have configured port forwarding to the server; both 80/81. Should it be in a DMZ instead?
    3. I have a DYNDNS site: that is forwarded to my Apache and ISPConfig server (80/81). I cant see the ISPConfig site from their. Is it a Fedora firewall problem?
    4. Is their a way of changing the username/password to logon to ISPConfig homepage without being logged in?
    5. When setting up MySQL i think i used a user name of test instead of root could this be the problem im having when trying to logon to ISPConfig? How do i change that if its the problem?

    Thanks for your patience.
    Last edited: May 12, 2006
  7. falko

    falko Super Moderator Howtoforge Staff

    Please check if the ISPconfig database exists and if there a tables with records in it:

    Did you disable SELinux and the firewall as shown in the FC5 howto?

    I don't understand that question... :confused:
    You mean during the ISPConfig installation you specified test as MySQL user instead of root? That's a serious problem, that explains why you can't login. The only solution would be to delete ISPConfig and install it again...
  8. nubtool

    nubtool New Member

    Looks like i will be doing a fresh install. :rolleyes:

  9. skin

    skin New Member


    I entered "localhost" and it asks for my user and pass. I enter "admin" "admin" and is says the password is incorrect.

    I also entered "admin" and for my password I entered my other password I entered for everything else on this install. I also tried root as a login but I do not know the password apparently?

    I also had skipped this step...
    mysqladmin -h -u root password yourrootsqlpassword

    per this post...

    I still had planned to finish that step but just had skipped it for then. Until now I had forgotten about it. I figure that is relevant to the issue at hand.

    Last edited: May 16, 2006
  10. falko

    falko Super Moderator Howtoforge Staff

    You must use root and the password for the MySQL user root (the one you specified with
    mysqladmin -u root password yourrootsqlpassword
  11. skin

    skin New Member


    I have started from scratch. Brand new Fedora install... Same how-to.


    When I get to this step...
    mysqladmin -h server1.********.com -u root password ********
    I get...
    mysqladmin: connect to server at 'server1.*******.com' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'

    I am very thankful for your help!

  12. till

    till Super Moderator Staff Member ISPConfig Developer

    I think you can ignore that and proceed with the next steps. After you finished the installation and installed the ISPConfig phpmyadmin package, you can login and make sure that a password is set for the root user when he connects from server1.....
  13. skin

    skin New Member

    I think that is where the problem occurs... During the ISPConfig install, it asks for the MYSQL Server, login, and password. It gives me an error at that point also.
  14. falko

    falko Super Moderator Howtoforge Staff

    Have a look here:

    You must enter localhost, root and then the password.
  15. jesus2539

    jesus2539 New Member

    i did this and i'm getting this Error: centos 5.0 your operating system is not supported
  16. falko

    falko Super Moderator Howtoforge Staff

    Please download the latest ISPConfig version which is 2.2.23. 2.2.2 is very, very old and does not support the newer distributions.

Share This Page