New Sites, DB's, Users, etc not being created

Discussion in 'Installation/Configuration' started by frument, Feb 17, 2010.

  1. frument

    frument New Member

    So this seems to be a very unique issue. I have a fresh install of ISPC3. I added two sites, DB's, Users, and every thing was great. I migrated the sites to the ISPC3 server, worked out all the kinks, and the sites a running great.

    Now I go back to ISPC3 panel to add in two new sites, and nothing is created (ie no dir's, no *.vhost). I tried adding in new users, nothing is created. I also tried adding new DB's, to no avail. I had a look in /var/log/ispconfig/ispconfig.log for any errors, it is completely empty. I then tail -f syslog to see what might be going on and it shows:
    Feb 17 09:40:05 frument01 postfix/qmgr[3295]: B0CD1E86FF: removed
    Feb 17 09:41:01 frument01 CRON[6152]: (root) CMD (/usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log)
    Feb 17 09:42:01 frument01 CRON[6192]: (root) CMD (/usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log)
    Feb 17 09:43:01 frument01 CRON[6232]: (root) CMD (/usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log)
    Feb 17 09:44:01 frument01 CRON[6243]: (root) CMD (/usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log)
    Feb 17 09:45:01 frument01 CRON[6279]: (getmail) CMD (/usr/local/bin/ > /dev/null 2>> /var/log/ispconfig/cron.log)
    Feb 17 09:45:01 frument01 CRON[6280]: (root) CMD (/usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log)
    Feb 17 09:46:01 frument01 CRON[6322]: (root) CMD (/usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log)
    Feb 17 09:47:01 frument01 CRON[6363]: (root) CMD (/usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log)
    Nothing really pointing me in any direction...

    Not sure where to go with this, anyone have any ideas?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the command:


    as root user on the shell manually. Do you get any errors?
  3. frument

    frument New Member

    Running /usr/local/ispconfig/server/ returns no errors, but nothing is created. I tried that shortly after writing the initial post. Also tried running ispconfig_update to verify I was running the latest version, I am.

    Also I still see nothing in /var/log/ispconfig/ispconfig.log

    Here is some info on the server.

    [email protected]:/var/log# php -v
    PHP 5.2.10-2ubuntu6.4 with Suhosin-Patch 0.9.7 (cli) (built: Jan  6 2010 22:56:44)
    [email protected]:/var/log# cat /etc/lsb-release
    Last edited: Feb 17, 2010
  4. frument

    frument New Member

    Found my issue. :eek:

    So I got down to basics and checked to see if my network settings between ISPC3 and /etc/network/interfaces where correct. Sadly this was not the case.

    System > Server Config > Server

    I added in the correct Gateway and DNS Servers. Initially they had the default 192.168.0/24 info. Changed it and everything is right as rain. It's very interesting that the wrong network config would stop ISPC# from creating sites after some time. Why would this not be the case from the get-go?

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The network settings dont get used by ispconfig (its disabled by default, thats why they do not match the data in /etc/network/interfaces), so your problem must have been something else. But good to see that its working now.

Share This Page