NextCloud cron error (Ubuntu 22.04)

Discussion in 'General' started by kcafe703, Jan 12, 2023.

  1. kcafe703

    kcafe703 New Member

    System Information
    Ubuntu Version: 22.04
    Kernel Version: 5.15.0-57-generic x86_64
    PHP Version: 8.0

    When setting cron, it is not normally applied. After 10 minutes, the following message is displayed.
    'Last background job execution ran 10 minutes ago. Something seems wrong.'
    Here's how I tried to fix this problem.

    Modify crontab
    crontab -u www-data -e
    */5 * * * * php -f /var/www/clients/client0/web2/web/cron.php
    Problem still not resolved.

    Add --define apc.enable_cli=1 to cron
    Problem still not resolved.

    Modify apcu.ini
    Add apc.enable_cli=1 to /etc/php/8.0/mods-available/apuc.ini
    Problem still not resolved.

    Replacing memory caching from APCu to Redis

    Problem still not resolved.

    I've tried most of the possible solutions, but the problem hasn't been resolved.
    Is this a problem because the website owner and group are not www-data:www-data?
    Last edited: Jan 12, 2023
  2. kcafe703

    kcafe703 New Member

    Is this a problem because the website owner and group are not www-data:www-data?
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    kcafe703 likes this.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, you created a wrong cronjob. Remove the cronjob you manually created under the wrong user. Then log in to ISPConfig and create a cronjob for the website inside ISPConfig.

    Most likely even a URL cronjob works for this, so you can just put:


    in the command field of the cronjob. If this does not work, create a normal cronjob in ISPConfig.
    kcafe703 and pyte like this.

Share This Page