NGINX problem after ISP Config Automated installation on Debian

Discussion in 'Installation/Configuration' started by Alextoch, Aug 21, 2017.

  1. Alextoch

    Alextoch New Member

    Hello everybody,

    I have used the automated script on debian 9 : ispconfig-install-script-debian (on howtoforge)
    All is working great except NGINX.

    Indeed, i can add websites on all ports except the ports 80 or 443 :eek:

    By default, in ISPconfig, when I create a website, the port 80 or 443 is used. Creation of websites does not work. Then, I go to /etc/nginx/sites-available, to see what is the problem.
    Config files seems good but after a lot of tests, I notice if I change the default port 80 or 443 by another port like 8181, it works !!!

    I do a netstat to see if the port 80 / 443 is already used by another vhost :
    sudo netstat -paunt | grep nginx
    tcp 0 0* LISTEN 30071/nginx: master
    tcp 0 0* LISTEN 30071/nginx: master
    tcp 0 0* LISTEN 30071/nginx: master

    So, yes it's normal, ports are already in used. However, if I check all vhost in/etc/nginx/sites-available, there is no vhost with the port 80 or 443 configured (I have deactivated the default vhost).
    When I go to mydomain.tld (port 80), there I have a gateway timeout (error 504).
    When I go to mydomain.tld (port 443), I have the nginx welcome page.

    So I tried to find a vhost in another directory, I find another default one (?) in <user>/.local/share/letsencrypt/lib/python2.7/site-packages/certbot_nginx/tests/testdata/etc_nginx/ubuntu_nginx_1_4_6/default_vhost/nginx/sites-available/
    This one was configured to the port 80.

    I have removed it and reload it. But nothing change. I don't find any other vhost now but the problem remains the same.

    After, you will find a status on nginx
    nginx -V
    nginx version: nginx/1.10.3
    built with OpenSSL 1.1.0f 25 May 2017
    TLS SNI support enabled
    configure arguments: --with-cc-opt='-g -O2 -fdebug-prefix-map=/build/nginx-2tpxfc/nginx-1.10.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-z,relro -Wl,-z,now' --prefix=/usr/share/nginx --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/ --modules-path=/usr/lib/nginx/modules --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-debug --with-pcre-jit --with-ipv6 --with-http_ssl_module --with-http_stub_status_module --with-http_realip_module --with-http_auth_request_module --with-http_v2_module --with-http_dav_module --with-http_slice_module --with-threads --with-http_addition_module --with-http_geoip_module=dynamic --with-http_gunzip_module --with-http_gzip_static_module --with-http_image_filter_module=dynamic --with-http_sub_module --with-http_xslt_module=dynamic --with-stream=dynamic --with-stream_ssl_module --with-mail=dynamic --with-mail_ssl_module --add-dynamic-module=/build/nginx-2tpxfc/nginx-1.10.3/debian/modules/nginx-auth-pam --add-dynamic-module=/build/nginx-2tpxfc/nginx-1.10.3/debian/modules/nginx-dav-ext-module --add-dynamic-module=/build/nginx-2tpxfc/nginx-1.10.3/debian/modules/nginx-echo --add-dynamic-module=/build/nginx-2tpxfc/nginx-1.10.3/debian/modules/nginx-upstream-fair --add-dynamic-module=/build/nginx-2tpxfc/nginx-1.10.3/debian/modules/ngx_http_substitutions_filter_module

    I really don't understand why it does not work and why ports 80 and 443 are used by nginx (with no vhost configured with these ports).

    Do you have any idea to solve this problem ?

    Thanks a lot !!!!

Share This Page