now what about these mounting points

Discussion in 'Installation/Configuration' started by --::wizZzard::--, Jan 17, 2006.

  1. --::wizZzard::--

    --::wizZzard::-- New Member

    at first my dedicated server has an 80GB HD.

    my /etc/fstab looks like this:

    #<file sys> <mount point> <type> <options> <dump> <pass>
    /dev/hda1 / ext3
    rw,errors=remount-ro,usrquota,grpquota 0 1
    /dev/hda2 none swap rw 0 0
    none /proc proc defaults 0 0
    /dev/hda3 /home ext3 rw 0 2
    none /proc/bus/usb usbdevfs defaults
    /dev/fd0 /floppy auto users,noauto 0 0

    to me (an complete Linux newbie) seems as there are 3 hardrives, or partitions and one Floppy mounted.

    my ISPConfig sais to me that on hda1 are 5GB on hda2 237MB and hda3 are 67GB. this all is ok!

    to hda1 is mounted: /
    to hda3 is mounted /home

    my web server data directory is /var/www

    is this directory now on hda1? yes?

    how do i get it to hda3 (without loosing all the data in it)? because this seems to me is the best way of using all the space for an server which only provides an Web and Mailserver.
  2. falko

    falko Super Moderator Howtoforge Staff

    Yes, you have 3 partitions, one of them is swap space.


    mv /var/www /home/www
    Then replace all occurrences of /var/www with /home/www in your Apache configuration file and also in the files that are included in your Apache configuration file. Afterwards, restart Apache.
  3. --::wizZzard::--

    --::wizZzard::-- New Member

    must i also alter ISPConfig configuration? Or only apche2 config?
  4. nveid

    nveid New Member

    Judging by the demo site, it seems /home/www is what ISPconfig defaults to access those files.

    So I'd say best bet modify your apache configuration files where its looking from /var/www to /home/www
  5. falko

    falko Super Moderator Howtoforge Staff

    I didn't know that you have ISPConfig installed. Yes, you must change the ISPConfig configuration. Adjust the values in the table isp_server, in Vhosts_ispconfig.conf, the users' homedirs in /etc/passwd. I hope I didn't forget anything.
    Restart Apache afterwards.
  6. --::wizZzard::--

    --::wizZzard::-- New Member

    so, now that my exams are over i tried to make the changes, apache2 itself works properly. but the php or pear (i am not quit familiar whats the difference) isn't working.

    i looked through the files in /etc/apache2/mods-enabled/ but there arent any /var/www/ strings in it. where is php4 or pear also configured?

    ^^problem solved, it was only an absulute path saved in my joomla config file (wich now points also to /home/www/ )

    But now:

    Where do i find the file "Vhosts-ispconfig.conf" and the table "isp_server" ?

    In ISP Configs Web Interface i altered all entries from /var/www to /home/www
    Last edited: Feb 27, 2006
  7. falko

    falko Super Moderator Howtoforge Staff

    Do you use Debian Sarge? Then Vhosts_ispconfig.conf is in /etc/apache2/vhosts.
    The table isp_server is in the ISPConfig MySQL database. You can use phpMyAdmin to access it.
  8. --::wizZzard::--

    --::wizZzard::-- New Member

    oh, then i already alterd Vhosts_ispconfig.conf :) and as i see the table was perfectly altered by ISPConfig itself through the Webinterface, where you can enter the webservers document root!

    so i think for now are no more problems, i hope so! :D
  9. --::wizZzard::--

    --::wizZzard::-- New Member

    i have found one problem :eek:

    in the /home/www/ there are located the web# and there corrosponding link files.

    but after the changes, the link files aren't working anymore. how do i change them?
  10. falko

    falko Super Moderator Howtoforge Staff

    Can you explain in more detail what you did and what is the problem now?
  11. --::wizZzard::--

    --::wizZzard::-- New Member


    for each web (web1 to web999 or something like that)
    ISPConfig creates some sort of LINK (don't know how else i could name it)


    web6 =

    /home/www/web6 is the root directory of the web ""

    before i made the changes, when i could simply go to my web root (when i logged in via SSH) by typing

    cd /var/www/ <return>

    now after the changes debian says that /home/www/ is not an directory

    i think through moving the whole directory the links are destroyed and i must renew them or something else, but i don't know how.
  12. falko

    falko Super Moderator Howtoforge Staff

    Please post the output of
    ls -la /home/www
  13. --::wizZzard::--

    --::wizZzard::-- New Member

    85-31-186-56:~# ls -la /home/www
    total 52
    drwxr-xr-x 12 root root 4096 Jan 25 13:51 .
    drwxrwsr-x 8 root staff 4096 Feb 28 01:50 ..
    drwxr-xr-x 2 root root 4096 Dec 23 17:24 apache2-default
    -rw-r--r-- 1 root root 19 Dec 24 16:48 info.php
    drwxr-xr-x 3 root root 4096 Jan 5 00:30 localhost
    drwxr-xr-x 2 root root 4096 Jan 4 00:41 sharedip
    drwxr-xr-x 2 root root 4096 May 24 2005 squid-reports
    drwxr-xr-x 8 web11 4096 Feb 28 00:09 web11
    drwxr-xr-x 8 web6_admin-wizzzard web6 4096 Feb 28 00:09 web6
    drwxr-xr-x 8 www-data web7 4096 Jan 8 04:00 web7
    drwxr-xr-x 8 web8 4096 Feb 28 00:09 web8
    drwxr-xr-x 9 web9 4096 Feb 28 00:09 web9
    drwxr-xr-x 2 root root 4096 Dec 23 17:24 webalizer
    lrwxrwxrwx 1 www-data web11 14 Feb 27 23:39 -> /var/www/web11
    lrwxrwxrwx 1 www-data web7 13 Feb 27 23:39 -> /var/www/web7
    lrwxrwxrwx 1 www-data web8 13 Feb 27 23:39 -> /var/www/web8
    lrwxrwxrwx 1 www-data web9 13 Feb 27 23:39 -> /var/www/web9
    lrwxrwxrwx 1 www-data web6 13 Feb 27 23:39 -> /var/www/web6

    so, but how do i edit this links? they point to the old directory!
  14. falko

    falko Super Moderator Howtoforge Staff

    You do it like this:
    cd /home/www
    rm -f
    ln -s /home/www/web11
  15. --::wizZzard::--

    --::wizZzard::-- New Member

    THX a lot. I hope this was the last problem! :D

Share This Page