One user can get e-mail but another can't...bizarre...

Discussion in 'Installation/Configuration' started by cazarhosting, Jan 4, 2009.

  1. cazarhosting

    cazarhosting New Member

    I'm having a rather weird problem. It may be something very small I'm overlooking, as I am as much a newbie to linux as I am to ISPConfig. Anyway...

    I set up a CentOS 5.2 machine using "The Perfect Server" instructions ( Everything went pretty smoothly, and I was logged into ISPConfig in no time.

    Here's a quick rundown of my configuration:

    -Cable internet service w/dynamic IP address
    -Wireless router uplinked to cable modem
    -CentOS server box hard-wired to router via one of the standard RJ-45 ports
    -Network set up on
    -Router set up as gateway -
    -Router set to use OpenDNS ( / for DNS service
    -Server set up with static IP -
    -Router set up with DynDNS service to always point "{my host name}" to my router's current IP address.
    -Router set up to "Port Forward" all standard services (FTP, HTTP, HTTPS, SMTP, POP3, VNC ports 5901-5902 and ISPConfig port 81) to the server at

    I set up a reseller account and set up two sites under that -- one for my site, and one for a friend's business. Both sites' domain names were registered with a major registrar and both sites have CNAME and MX records that point directly to "{my host name}" for their respective mail servers. (Since I am using dynamic DNS service, I wasn't easily able to set up my server as a DNS server, so I left the DNS records to be managed at the registrar.)

    So then I set up e-mail accounts under each site. I configured the e-mail account for my site to be received via Microsoft Outlook 2003 (POP3) on my laptop. No problem -- connections tested out fine, and I was able to send and receive test e-mails to/from other accounts, both local and external. This e-mail account has been running just fine for about two months now.

    So recently I migrated my friend's website to my server and set him up with a similar e-mail address under his site in ISPConfig. I configured his e-mail account to be received via Microsoft Outlook Express 6 on his laptop (also POP3). Similar story -- the connections tested out fine and reported no errors. I was able to SEND e-mails FROM his account and receive them on both internal and external accounts.

    Now comes the problem -- I tried sending e-mails TO his new account, both from internal and external accounts. The e-mails seem to send fine and don't ever get bounced back. He runs Send/Receive on Outlook Express on his laptop, it connects fine, runs through the process fine, but NO E-MAILS COME THROUGH. The process finishes with NO ERRORS reported.

    I checked Maildir, and the messages are all still there on the server (still waiting to be pulled down...?) so I know they were delivered properly.

    I checked /var/log/mail -- no errors. I could even see where the connections were being made from his laptop (via Outlook Express) and then closed without incident.

    I checked through all the settings in ISPConfig for both e-mail accounts, and they are identical except for the e-mail addresses, the usernames and the passwords.

    I even went as far as to configure his e-mail account in Microsoft Outlook 2003 on my laptop and see if I could pull the messages down that way -- no luck, same problem; it connects fine and finishes fine, but no e-mail messages come across.

    I am still able to send and receive e-mail messages using my e-mail account, so I know that ISPConfig is working properly.

    Unless there is some strange obscure setting that I am missing in a config file somewhere, I have no idea why this is happening.

    If anyone can give me any clues, I would greatly appreciate it. Thanks!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which messages or errors appear in the mail log when you send such an email that dissappears?
  3. cazarhosting

    cazarhosting New Member

    From /var/log/maillog

    Below is the portion of the mail log showing me ([email protected]) sending an e-mail to friend ([email protected]), then friend attempting to retrieve e-mail via POP3 through Microsoft Outlook -- still same result, no messages pulled down.

    Jan 6 00:33:48 server postfix/smtpd[1915]: connect from unknown[]
    Jan 6 00:33:49 server postfix/smtpd[1915]: 159101941FC: client=unknown[], sasl_method=LOGIN, sasl_username=cazarhostingadmin
    Jan 6 00:33:49 server postfix/cleanup[1920]: 159101941FC: message-id=<[email protected]>
    Jan 6 00:33:49 server postfix/qmgr[1211]: 159101941FC: from=<[email protected]>, size=2507, nrcpt=1 (queue active)
    Jan 6 00:33:49 server postfix/local[1921]: 159101941FC: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.22, delays=0.19/0.03/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)
    Jan 6 00:33:49 server postfix/qmgr[1211]: 159101941FC: removed
    Jan 6 00:33:51 server postfix/smtpd[1915]: disconnect from unknown[]
    Jan 6 00:37:11 server postfix/anvil[1918]: statistics: max connection rate 1/60s for (smtp: at Jan 6 00:33:48
    Jan 6 00:37:11 server postfix/anvil[1918]: statistics: max connection count 1 for (smtp: at Jan 6 00:33:48
    Jan 6 00:37:11 server postfix/anvil[1918]: statistics: max cache size 1 at Jan 6 00:33:48
    Jan 6 00:38:21 server dovecot: pop3-login: Login: user=<info>, method=PLAIN, rip=::ffff:, lip=::ffff:
    Jan 6 00:38:21 server dovecot: POP3(info): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0

    I'm wondering if it may have anything to do with the 'to=<[email protected]>, orig_to=<[email protected]>' line?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, the mail was redirected to the root account. Please take a look at the /etc/aliases if you have there any alias for info, if yes, remove it and run the newaliases command.
  5. cazarhosting

    cazarhosting New Member


    That did the trick -- thank you!

Share This Page