OpenLDAP + Samba Domain Controller On Ubuntu 7.10

Discussion in 'HOWTO-Related Questions' started by mperreault, Jun 18, 2008.

  1. mperreault

    mperreault New Member

    I'm following the tutorial called
    OpenLDAP + Samba Domain Controller On Ubuntu 7.10

    I finished up until page 2 of the tutorial without any problem but after the reboot process I can't seem to login... When I type my username and hit enter it hangs and 60 seconds later it gives me an error without asking for a password...

    I'm new to linux, so if you could hold my hand a little I'd greatly appreciate it...:rolleyes:

  2. Linocks

    Linocks New Member

    Have a look at this 'Thread'. I think it may solve your problem.;)
  3. mperreault

    mperreault New Member

    Thanks Linocks!

    I have 2 other questions.

    1. I have the server up and running and I have a WinXP machine bound to my newly created domain. I was wondering if I wanted to take this HOW-TO a step furthur and allow the user documents folder to map to the server any suggestions on what I should do?

    2. phpLDAPadmin doesn't seem to quite work properly. I am able to login anonymously however when I try to login I get the following error...

    Could not bind to the LDAP server.

    LDAP said: Undefined attribute type
    Error number: 0x11 (LDAP_UNDEFINED_TYPE)
    Description: The attribute type specified is invalid.

    Thanks for any info people can give me!
  4. sangamc

    sangamc New Member

    for the first part, i use the following logon.bat in the samba netlogon folder

    cd H:
    IF NOT EXIST "H:\My Documents\." MD "H:\My Documents"
    regedit /s \\fds8\netlogon\redirect.reg

    # H: is the user home directory specified in smb.conf
    # redirect.reg will set the registry for redirecting my documents

    to create redirect.reg, logon to to your windows xp computer that is part of the domain, make sure the H: drive is mapping correctly. manually create a 'my documents' folder. modify this registry entry to redirect my documents.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Personal]

    change the value of the key to \\%L\%U\My Documents
    (im not sure if this is the correct value since im not by the computer)

    export the registy key to redirect.reg then copy redirect.reg to your netlogon folder so that the batch file can find it.

    now when a user logs is, My documents is redircted to %L = servname\%U = User folder\ My Documents <<< which is created if it does not exist already.

    i hope this helps. i can clarify more once i get by a computer with the settings already there.
  5. mperreault

    mperreault New Member

    Webmin and file

    I'm walking through this tutorial again and I've got to page 3... I've logged into webmin and I'm trying to complete the first step on page 3...

    When I clicked on BIND DNS Server it claimed a component was missing and offered to install it.. When it completed i was shown a screen that said..

    When I click any of the above options I'm given the same error..

    So I'm a little stuck as to how to proceed from here.. ??? :confused:

    Any help would be greatly appreciated!!!
  6. sangamc

    sangamc New Member

    have you tried uninstalling bind and re installing it from the command line instead of using webmin to install the package?
  7. mperreault

    mperreault New Member

    Thanks Sangamc that worked...

Share This Page