pear and change_sqlpass plugin

Discussion in 'Installation/Configuration' started by sruedat, Jan 14, 2010.

  1. sruedat

    sruedat New Member

    Hello, I have tried to install the squirrelmail plugin change_sqlpass, so my clients can change they own password... but when I active the plugin this happen:

    What happen?

    I'm on suse 11.1

    pear -V said:
    PEAR Version: 1.5.0
    PHP Version: 5.2.11
    Zend Engine Version: 2.2.0

    and pear install DB said:
    pear install DB
    Channel does not support xml-rpc method package.getDownloadURL
    Cannot initialize 'DB', invalid or missing package file
    Package "DB" is not valid
    install failed

    thanks for your help.
  2. sruedat

    sruedat New Member

    it was my fault, i have a problem in the config.php file.... i'm forggot "<?php", i'm i idiot...sorry.

    But now in the webmail adress only appears a blank page... I'm doing somethin wrong.

  3. falko

    falko Super Moderator ISPConfig Developer

    Please make sure you introduced no PHP syntax error when you modified the config.php file of the change_sqlpass plugin.
  4. sruedat

    sruedat New Member


    I had followed this tutorial...and I had used this code.

    Now I have used the config.php.sample... and the problem is solved;

    But I think that I have problems with pear because when I try to change the pass this happen: "Could not find Pear DB library".

    If I do pear list I get this:
    Installed packages, channel
    Package Version State
    Console_Getopt 1.2.3 stable
    DB 1.7.13 stable
    PEAR 1.9.0 stable
    Structures_Graph 1.0.3 stable
    XML_Parser 1.3.2 stable
    XML_Util 1.2.1 stable

    Thanks for your infinite patient.
    Last edited: Jan 16, 2010
  5. falko

    falko Super Moderator ISPConfig Developer

    Try this:
    aptitude install php-pear
    pear install DB
  6. sruedat

    sruedat New Member

    I had done it yet...
    I have done it again, but I have the same problem...: "Could not find Pear DB library"

    I works in opensuse 11.1_X64: "yast -i php-pear php-pear-db"
    in fact if you see the pear list the DB package appears.
    Last edited: Jan 17, 2010
  7. falko

    falko Super Moderator ISPConfig Developer

    I have no idea why this happens... :(
  8. sruedat

    sruedat New Member

    I think the error is...

    What would be the log file?, this is the apache error_log:
    [Thu Jan 21 21:03:51 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Thu Jan 21 21:03:51 2010] [notice] Apache/2.2.10 (Linux/SUSE) mod_ssl/2.2.10 OpenSSL/0.9.8h PHP/5.2.11 with Suhosin-Patch mod_mono/2.0 configured -- resuming normal operations

    Last edited: Jan 21, 2010
  9. sruedat

    sruedat New Member

    I solved it

    I SOLVED IT!!! :D:D:D

    There was a problem with the pear config....
    The pear config-show must be so:
    Then I reinstalled the DB package and... it works

    The problems was a wrong configuration (you can change it with pear config_set <param1> <param2>)
  10. mutua

    mutua New Member

    Am experiencieng same problem! which conf pricesly were incorrect.

Share This Page