perfect server centos 5.2 - wont boot after installing Quota

Discussion in 'HOWTO-Related Questions' started by Layla Nahar, Apr 8, 2010.

  1. Layla Nahar

    Layla Nahar New Member


    I got to and when I power cycled my machine it was unable to boot. I posted here to find out if there is any way to correct this other than re-installing

    I power cycled after having done Ch 8 (Quota) and part of Ch 9 (BIND9)

    one of the steps for Ch 8 is to edit /etc/fstab, then run

    touch /aquota.user /
    chmod 600 /aquota.*
    mount -o remount /
    quotacheck -avugm
    quotaon -avug

    I has some trouble with mount -o remount / but then I fixed a typo in /etc/fstab and the command seemed to complete without any message.

    When I booted I got the error:
    fsck.ext3: No such file of dirctory while tryin go open /dev/VolGroup00/LogVol100. The super block coun not be read or does not descip a correct ext2 file system ... you might try unning e2fsck with an alternate superblock

    the only other /dev/&c I have is the swap file.

    when I ran e2fsck -b 8193 /dev/VolGroup00/LogVol100 I got the message "No such file of dirctory while tryin go open /dev/VolGroup00/LogVol100"

    Is there a way I can fix this without reinstalling the OS?

    Thank you

    I'm prepared to reinstall, but it would be nice to avoid it. (It took between 2 - 3 hrs to install ...)

    ps - I didn't make a copy of fstab before editing. I expect that is the last time I will make that mistake...
  2. falko

    falko Super Moderator ISPConfig Developer

    You could boot from a Live-CD and take a look at your fstab - I guess you made an error in there.
  3. Layla Nahar

    Layla Nahar New Member

    Thank you Falko for answering my post. I tried using the rescue feature of the CD. fstab and a lot of other files were missing from the /etc directory. I made a new copy of fstab from scratch, but I still got the same failure. I am re-installing.

    thanks again!

Share This Page