Perfect server setup for 7.04 - no internet

Discussion in 'Installation/Configuration' started by valtech, Jul 28, 2007.

  1. valtech

    valtech New Member

    Hi and thanks for a great tutorial!
    Ran into a slight problem that puzzled me. A bit of background info.
    Internet connection is provided by an ADSL modem-router, which has a PC (Ubuntu 6.10) connected to it by CAT5 and a laptop on the wireless (also with 6.10 on it). My new server is now also connected to it via CAT5. My ISP is Eclipse (UK) and the router WAN IP is 'auto/assigned by ISP'.

    Previouslly, I've setup for using DHCP and all worked OK. All computers got onto internet, inc. the new server.

    Now I configured the router and the other PCs on the same network to use static IP, done the mods described on p3 of the tutorial to the server config files to convert to static IP and assign server name. I gave the server its IP address (unique one), changed the other two values to match up with network IP settings.
    I got in /etc/network/interfaces:

    # The primary network interface
    auto eth0
    iface eth0 inet static
    gateway <===== router IP

    and in /etc/hosts: localhost localhost server1

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    Restarted everything.

    What I got now is all PCs connect to internet OK, but the server cannot. It
    correctly responds to 'hostname'.
    Found this out while attmepting to get updates.
    I can ping all PCs and the router from the server and vice versa.

    Had a look at the router setup and network name for LAN was set to valtechcomputers, so I thought this may conflict, so I changed /etc/hosts/ to: server1.valtechcomputers <==== dropped the .com
    Still the same - pings but no internet on server.
    Then, thinking that the network/domain name should be in format changed the other way round - router to and the /etc/hosts/ to the same.
    No change.
    Re-intalled Ubuntu and followed the procedure to the point just before editing /etc/hosts, thinking the host setup may have confused the matters.

    Any ideas? Is this to do with me being on variable IP on the WAN side? I know Eclipse can provide a static IP - worth doing?
    It must be something very silly that I'm doing (or not!) to get into this situation. As I said, all works OK when set to DHCP, regardless of the network name setup in the router.

    Sorry about such a long post!
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    route -nee
    with the current (not-working) setup and with the preious setup where you used DHCP?
    What's in /etc/resolv.conf?
  3. valtech

    valtech New Member

    Could not believe this!
    Powered up this morning and off it went with the updates! Without any changes made and still set up for static IP! Thank you for your kind help. I only wish I knew what caused it to not connect last time!

Share This Page