Perfect Server Setup RoundCube Fails

Discussion in 'Installation/Configuration' started by Frank32, Mar 8, 2020.

  1. Frank32

    Frank32 New Member

    Perhaps I missed something while following the steps of "The Perfect Server - Debian 10 (Buster) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1", but RoundCube fails to install. I installed two servers and everything works just fine, except RoundCube.

    Apparently the problem lies with database access. After entering:
    echo "CREATE DATABASE roundcube;" | mysql --defaults-file=/etc/mysql/debian.cnf

    the following error message is returned:
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

    I could solve this problem by putting the username and password in debian.cnf in double quotes, like "root" instead of root. Installation continues until the point where the installer asks the questions:
    - Configure database for roundcube with dbconfig.common? <-- yes
    - MySQL application password for roundcube: <-- press enter

    Installation fails with the following output:
    - Creating config file /etc/dbconfig-common/roundcube.conf with new version
    - Creating config file /etc/roundcube/debian-db.php with new version
    - ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES).
    - unable to connect to mysql server.
    - error encountered creating user:
    - ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

    I checked by logging in: mysql -u root -p and I can log in just fine. Is this a RoundCube problem?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No, you probably restarted or reloaded MariaDB anywhere in between while the tutorial does not do that. In that case, you can use the command with -p parameter. I've installed the guide on a server on Friday, copy/paste and works without any changes needed.
  3. Frank32

    Frank32 New Member

    I cannot recall deviating from the tutorial, but maybe you're right. In any case, installing RoundCube by following the tutorial, which starts with echo "CREATE DATABASE roundcube;" | mysql --defaults-file=/etc/mysql/debian.cnf should work, right? If so, can it be an issue to have the login data in double quotes in debian.cnf?

Share This Page