permission denied or not permited

Discussion in 'Installation/Configuration' started by psychop, Nov 18, 2011.

  1. psychop

    psychop New Member

    Checked all posts regarding permissions on server.
    ISPConfig 2.2.40 on Suse 11.4
    Have simple php code for uploading images on server into dir images. If chmod is set to 777 is uploaded ok else get error: Operation not permitted

    Owner is web6_net:web6, but owner of uploaded file is wwwrun:www and here seems to be the problem

    How to setup files that when new ispconfig user and site is created that rights will be 755 and php would be able to upload files to some dir.

    PS: tried chmod($mydir, 0777) and also get -> chmod(): Operation not permitted

    Tnx for help.
  2. falko

    falko Super Moderator ISPConfig Developer

    Just make the upload directory owned by wwwrun:www.
  3. psychop

    psychop New Member

    Tnx for reply.

    Already tried that but then can't upload and edit files from ftp. So have to find solution that both (for example) web6 and www groups work at same time with same files.
  4. psychop

    psychop New Member

    Solution: add users to group and change ownership to that group and change permission to 0775 !

Share This Page