Permissions Issue

Discussion in 'Installation/Configuration' started by spikes, Mar 2, 2013.

  1. spikes

    spikes Member


    webserver: apache
    linux: debian sqeeze

    I have recently upgraded to and it seems I have a permissions problem. I have previously made a folder var/www/clients/client0/web1/file/ with sub-folders to hide them from normal web access. After upgrade it seems the script cannot access the folder any more

    Cache Directory "/var/www/clients/client0/web1/file/cache" not writeable

    I have checked permissions of folder

    drwxr-xr-x 15 web1 client0 4096 Mar 2 10:57 file

    It looks like the script should still be able to access the folder but everything has stopped working.
    Last edited: Mar 2, 2013
  2. falko

    falko Super Moderator ISPConfig Developer


    chattr -i /var/www/clients/client0/web1/file
  3. spikes

    spikes Member

    I ran that but it does not seem to have made a difference, the condition is still the same.
  4. spikes

    spikes Member

    I am a bit stuck and need some more help. What else can I try? Thanks in advance.
  5. till

    till Super Moderator Staff Member ISPConfig Developer


    chattr -i /var/www/clients/client0/web1

    File locations like /var/www/clients/client0/web1/file are not supported anymore when you have folder protection enabled in ispconfig for security reasons. If you want to store files outside of the web dir, then use the new private directory:


Share This Page