php fpm versions conflict (7.2 vs 5.6)

Discussion in 'Installation/Configuration' started by psvec, Jun 2, 2018.

  1. psvec

    psvec New Member

    I'm using ISPConfig with various versions of php. On one website I have strange problem. I have a website using the php 7.2. When I run phpinfo() I see
    PHP Version 7.2.5-1+0~20180505050007.21+jessie~1.gbpca2fa6
    $_SERVER['ORIG_SCRIPT_NAME'] /php5-fcgi
    $_SERVER['ORIG_SCRIPT_FILENAME'] /var/www/clients/client1/web15/cgi-bin/php5-fcgi-*-443-domain

    One of my websites is not running, in error log I see FastCGI error
    FastCGI: server "/var/www/clients/client1/web15/cgi-bin/php5-fcgi-*-443-domain" stderr: PHP message: PHP Fatal error:

    I don't understand why is it starting old php when it's configured to run 7.2.

    Thank you for some ideas...
  2. psvec

    psvec New Member

    The restart of all fpm services solved this problem :)

    ahrasis likes this.
  3. Well-Known Member HowtoForge Supporter

    remember, if you have configured additional php-fpms in ispconfig, all of them need one default config. Otherwise service doesn't start ( nothing to do ) and next time someone switches versions the mixup is perfect.

    Sometimes it says error 500, sometimes it gives different php-version ... probably depends on wether you defined to use sockets ( use them if possible ) or tcp listener.

Share This Page