Discussion in 'Installation/Configuration' started by sharwei, Apr 24, 2008.

  1. sharwei

    sharwei New Member

    I have been trying over a week and a half to get everything set up on my server. Basically I need memcache, openssl, libcurl and quite a few other things.

    Everything seems to be installed fine, except for one thing:

    When I use phpcurl and try to go to an 'https site', I do not get any response back. I can get a response back from going to a regular 'http site', such as, and can read the html I get back.

    The strange thing is that when I go to my own 'https site', where I created my own ssl cert, I can view the html that comes back. This might be because it is on the same server, but I set up the hosts file so it does not go through localhost.

    Anyways, I have been trying to figure this out for quite a long time and have bene chalking it up to a learning experience. But a week and a half is much too long....

    Anybody have any suggestions at why I can't view https pages, and/or anything I should look at in my installation?

    Any help is GREATLY appreciated!
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your log files?
  3. sharwei

    sharwei New Member

    No, there are no errors. I just get nothing back from the response. And actually I mispoke, this does not work for my own https server either. So any https server I'm trying to connect to, I get no response back.

    I have SSL_VERIFYHOST and SSL_VERIFYPEER both set to false as well.

    This worked fine before, and now I have new PHP I compiled. Haven't touched the code at all, or anything else, just PHP. Not sure why it would break because of this.
  4. sharwei

    sharwei New Member

    I am getting this error back:
    ERRNO: 26
    ERR: Failed to open/read local data from file/application

    I would have no idea why any file is trying to be opened now, and before not. Would anyone have a clue as to what files may be trying to be opened/read by the system?
  5. falko

    falko Super Moderator ISPConfig Developer

  6. sharwei

    sharwei New Member

    Thanks Falko. I would assume its something wrong with some file/path/etc. I just would have no idea what file or path, and not sure how to find this information out.

    Its really weird, because I have not changed any code and yet it fails with the new compiled version of PHP. The one I was using that was installed with my SuSe system worked fine.

    I'll keep looking though...

    Any other thoughts?

Share This Page