PHP module warnings (Perfect Server)

Discussion in 'Installation/Configuration' started by effoo, Oct 27, 2018.

  1. effoo

    effoo New Member


    I followed the Perfect Server Guide for Debian 9 with Apache (again) and at the part for installing Apache2, PHP, FCGI, suExec, Pear, phpMyAdmin, and mcrypt I got some warnings for php modules.
    Basically it installs php7.0-bz2, php7.0-readline and php7.0-json and when it comes to setting them up, I get the same warning for all 3 modules. I shortened it to one example:
    Not replacing deleted config file /etc/php/7.0/mods-available/bz2.ini / readline.ini / json.ini
    WARNING: Module bz2 / readline / json ini file doesn't exist under /etc/php/7.0/mods-available
    Since none of these modules are mentioned in the guide, may I ignore these warnings?
    If not, how can I trigger "replacing a deleted config file"? Why doesn't it just create one if it's non-existent?

    Thank you
    Last edited: Oct 27, 2018
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The perfect server installation should be done on an empty server. The error message make me suspect you had something already on the host when you started installing ISPConfig.
    Those files should be in /etc/php/7.0/mods-available if the installation has been done according to the guide.
    If this is new installation, I suggest start again from the beginning. Make sure the host is empty when you start, as the guide advices. Then do the installation carefully following the guide.
  3. effoo

    effoo New Member

    Thank you for the quick reply. This is a re-install of ISPConfig and it is not possible to start from an empty host. I tried to clean up everything as good as possible but I might have missed those files.
    I haven't installed ISPConfig itself yet, so can I manually add those missing files somehow before I continue?
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Why is it not possible to start from an empty host? If you already have websitses or databases on that host, it is just a mess if you install ISPConfig and try to use those. Backup the data you have, make an empty disk partition and install OS and ISPConfig following the guide.
    If your setup is already messed up, I would not waste time trying to fix it.
  5. effoo

    effoo New Member

    Ok, I got that. I missed three php modules during my cleanup. Everything else is fine.
    So I would really like to "waste time" on fixing it (I simply don't know how yet) because afaik missing php modules can be deliver subsequently if php is not in use yet.

    I believe I fixed it. php7.0-bz2, php7.0-json and php7.0-readline were marked as 'manually installed' which prevented them from getting purged & autoremoved. I marked them with
    apt-mark auto php7.0-bz2
    apt-mark auto php7.0-json
    apt-mark auto php7.0-readline
    and removed php completely, before reinstalling it.
    Now the modules are now properly installed and loaded. The timestamps of the .ini files are matching the time of the installation. Also checked loading with:
    php -r 'print_r(get_loaded_extensions());'
    php -r 'print_r(phpinfo(INFO_MODULES));'
    I believe I can continue now...
    Last edited: Oct 27, 2018
    Jesse Norell likes this.

Share This Page