PHP & MsSQL just wont work.

Discussion in 'Server Operation' started by matthewjamesnewotn, Jan 3, 2007.

  1. matthewjamesnewotn

    matthewjamesnewotn New Member

    Hi, I'm new the the linux community and just followed the great tutorial on this site... The Perfect Setup - Ubuntu 6.10 Server (Edgy Eft). I'm trying to start migrate our servers over to linux from windows and I need PHP to connect to our old MSSQL 2000 server.

    I've read two tutorials on how to download the source of php edit it to have FreeTDS included in the source and then once I try and build the package and run a "dpkg-buildpackage" on the directories in both tutorials it gives me the following error.

    [email protected]:~/php5-5.1.6# dpkg-buildpackage
    dpkg-buildpackage: source package is php5
    dpkg-buildpackage: source version is 5.1.6-1ubuntu2.1
    dpkg-buildpackage: source changed by Martin Pitt
    dpkg-buildpackage: host architecture i386
    dpkg-buildpackage: source version without epoch 5.1.6-1ubuntu2.1
    debian/rules clean
    : No such file or directory
    ‘. Stop. No rule to make target `
    Any ideas of why both tutorial would give me the same error...

    Here are the two I tried to follow:

    Could it be a problem with different php versions? if so how do I get the source from old php sources to match theirs?

    Thanks for your help
  2. matthewjamesnewotn

    matthewjamesnewotn New Member

    Figured it out..

    The first tutorial had me create the following files... When I did the 2nd tutorial it was messing up because of those files. I deleted them and tried the 2nd one again and every thing went smooth...

    >>> GOOD TUTORIAL >>>

    >>Files I Had To Delete >>

Share This Page