php4 to php5 on ispconfig server

Discussion in 'Installation/Configuration' started by provell, Jun 18, 2009.

  1. provell

    provell New Member

    Hi all,

    I have setup a ispconfig/debian sarge server at the time with the perfect setup.
    Later I have upgraded debian sarge to etch but my php version was still 4.
    Currently etch has php5 packages but are not upgradet automaticaly.

    Before I upgrade from etch to lenny I would like to upgrade php4 to php5.

    Is that a smart thing to do and what would be the best way to do it.
    Would a "apt-get install php5" be enough?

    Will it affect anything regarding to ispconfig as it uses it's own php5 compilation?

    Thanks in advance.;)

    Rgds Edo
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    should work.

  3. provell

    provell New Member

    lost connection to database

    On my (vmware/test) ispconfig server I tried to do the upgrade.
    Just "apt-get install php5"
    It removes the php4 apache mod and then installs the php5 mod for apache and the php5 package.
    When I do a "a2dismod", I can see the php4 mod is removed and the php5 loaded.

    Then my the joomla sites say:
    Database Error: Unable to connect to the database:The MySQL adapter "mysql" is not available.

    It looks like php5/apache is unaware of the mysql server or the other way arround.
    I checked the php.ini for php5 but can't find much difference with the one of php4 concerning the MySQL server settings.:confused:

    I even installed the php5-mysql package but still no luck.

    Is there some configuration file I should adjust to make the two talk to each other again?

    Thanks in advance.

    Rgds Edo
  4. provell

    provell New Member

    found it, I think?

    Searching through the forum I found that the problem was that I was still missing some PHP5 modules/packages.

    From the lenny perfect setup I did:
    apt-get install libapache2-mod-php5 libapache2-mod-ruby libapache2-mod-python php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-pspell php5-recode php5-snmp php5-sqlite php5-suhosin php5-tidy php5-xcache php5-xmlrpc php5-xsl

    Only the php5-xcache package could not be installed.

    Is this a bit overkill to get php5 working?
    Can one of these packages misconfigure something?:eek:

    Thanks in advance.

    Rgds Edo
  5. falko

    falko Super Moderator ISPConfig Developer

    No, don't worry. :)
  6. provell

    provell New Member

    php -v


    The upgrade works fine.
    Apache is now using the php5 module.

    Only when I type "php -v" at the command prompt the debian/etch sytem still say's: version 4.4.4-8+etch 6. :confused:

    I gues the debian/etch system still uses the 4 version.
    Would it not be wise to have it use the just installed 5 version?
    If so where do I change that?

    Rgds Edo
  7. falko

    falko Super Moderator ISPConfig Developer

    It seems as if the command line PHP is version 4 still. Try this:
    apt-get install php5-cli
  8. id10t

    id10t Member

    Yup, its a matter of all the modules for php4 vs. php5 - just gotta install 'em all and remove the php4 ones.

    dpkg -l | grep -i php4

    Will show which php4 packages are still installed. Replace 'em with the php5 versions and remove the php4 versions.


Share This Page