phpmyadmin links not working

Discussion in 'Installation/Configuration' started by winsbury, Mar 13, 2020.

  1. winsbury

    winsbury Member

    I have a live server with active clients, but have just tried accessing phpmyadmin for the first time and it isn't working. Links from ISPconfig database admin page point to https://serverurl:8080/phpmyadmin but response is

    Not Found
    The requested URL was not found on this server.

    • ISPconfig 3.1.15
    • Ubuntu 18.04
    • Apache 2.4.29

    Months ago when this was installed I followed the perfect server instructions: including section 8 that says:

    Configure database for phpmyadmin with dbconfig-common? <-- Yes
    MySQL application password for phpmyadmin: <-- Press enter​

    It seemed odd at the time not to have a password but nevertheless I pressed enter as instructed expecting to be given an auto-generated one but no, nothing.

    There are plenty of references to phpmyadmin on the server so it seems it was installed
    ls -R | grep phpmyadmin​

    So how can I get access to PHPmyadmin from a browser and why is ISPconfig pointing to the wrong URLs ???
    Last edited: Mar 13, 2020
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is a fundamental misunderstanding from your side on what that password is: The password in that dialog is an internal password for phpmyadmin which it uses to communicate with its local settings storage. It is NOT a password that you as user would use to login to phpmyadmin. That's why it is the correct procedure to not enter a password there and let it's secure the connection between phpmyadmin and its local settings storage automatically.

    ISPConfig points to the URL that you have set for it to access under System > interface settings. if you haven't set a URL yet, then it might indeed be that the link is wrong.

    Find out where your phpmyadmin is installed, it#s probably under:


    and then enter that URL in ISPConfig under System > interface config.
  3. winsbury

    winsbury Member

    Understood. FYI much earlier versions of ISPconfig / phpmyadmin installation had provided a password at that stage hence my original comment.

    ISPConfig > System > Main Config > Sites > PHPMyAdmin URL is set to /phpmyadmin ( the default ) but any attempt to access via the server IP, or any of the client URLs suffixed with /phpmyadmin results in a 404. Note that all domains are HTTPS only.

    I have also tried changing that setting to [SERVERNAME]/phpmyadmin but no change in symptoms.

    Reading the ISPconfig 3.1 manual section 5.26.1 suggests how to fix this and indeed the required directory & symlink referred to did not exist so have now created them and added 'Alias /phpMyAdmin /usr/share/phpmyadmin' to /etc/apache2/conf.d/phpmyadmin.conf then restarted Apache using:
    mkdir /etc/apache2/conf.d/
    ln -s ../../phpmyadmin/apache.conf phpmyadmin.conf
    /etc/init.d/apache2 reload
    But I still get the same 404 error regardless of what URL I use.

    Can you see what if anything I am doing wrong ?

    PS: is conf.d even still a valid location ?... Apache 2.4.29 uses a different directory structure, in which case the ISPconfig Manual is out of date and what I have done above cannot work.

    There is no mention in etc/apache2/conf-enabled or etc/apache2/conf-available or apache2.conf of phpmyadmin.conf , could this be the issue ?
    Last edited: Mar 13, 2020
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely you did not activate apache2 correctly in phpmyadmin during install. To activate an option in an apt install dialog, you have to navigate to that option using tab key and then activate it with the space key, If you miss hitting space key, then the option is note selected and therefore not used, which means that phpmyadmin is not activated in apache and therefore will not work.

    First, undo the changes that you did in apache2.conf manually and remove that symlink that you added manually.

    Then run:

    dpkg-reconfigure phpmyadmin

    and take care to select and activate apache2 option when apt asks you.
    winsbury likes this.
  5. winsbury

    winsbury Member

    You sir, are hero ... yes it was the spacebar I missed, I had only highlighted the option and not got the asterisk in the Apache2 selection box.

Share This Page