Phpmyadmin not working

Discussion in 'Installation/Configuration' started by Guido64, Mar 16, 2016.

  1. Guido64

    Guido64 Member

    I installed ispconfig3 with help from The perfect server tutorial. I'm playing with it and figuring everything out. I discovered phpmyadmin doesn't work. Wen i create a database there is an icon you can click to go to phpmyadmin and open the database tables. This icon does not work. I found out i can set the phpmyadmin url in interface main config this url was already set but isn't working. Next i tried to fix it by make a soft link
    ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin and reload apache to create a alias for phpmyadmin this doesn't work either. Then i did dpkg-reconfigure phpmyadmin and again its not working no alias and no phpmyadmin.

    What is going on?
  2. Well-Known Member HowtoForge Supporter

    Usually /etc/phpmyadmin/apache.conf should already be linked to /etc/apache2/conf-available/phpmyadmin.conf
    Which is then linked to the conf-enabled folder. Please check this is the case.
    Guido64 likes this.
  3. Guido64

    Guido64 Member

    There wasn't and isn't any phpmyadmin in conf-available and conf-enabled and even wen i make the soft llink myself phpmyadmin is stil not reachable wen i run a2enconf phpmyadmin results in not found while i created the softlink realy weird.

    In databases index in ispconfig there is this icon you can click to go to phpmyadmin that results in a not found error page.
    I currently putting back a backup again because i run dpkg-reconfigure phpmyadmin so i'm not confident this reconfigure went right.
  4. Guido64

    Guido64 Member

    Oke I destroyed this vps and recreated the ispconfig vps from a backup but I stil have this phpmyadmin problem. How can i solve this?
  5. Well-Known Member HowtoForge Supporter

    Make sure it is /etc/apache2/conf-available/phpmyadmin.conf
    Then $a2enconf phpmyadmin will work
    Guido64 likes this.
  6. Guido64

    Guido64 Member

    Oke now it seems to work. After I restored my ispconfig3 vps. I reconfigured phpmyadmin and make again the softlink to apache available and run a2enconf phpmyadmin now it does work. Yesterday i did the same but probably maybe some typo. It was late so that must be it ;) The tooltips however in ispconfig3 databases still do not work. I can click on them then phpmyadmin opens thats works but wen i hover over de icons i see a little thinge showing up what a tooltip should be but the tooltip is not showing.
    Thank you again and hopefully talk to you soon again because lots of other problems still to solve before I can use this ispconfig3 vps to host my websites. Up to the next one :)
    Last edited: Mar 16, 2016 likes this.
  7. Well-Known Member HowtoForge Supporter

    Indeed, I have the same issue with missing tooltips, never recognized they're even there until now. Could be missing translation or something like that, haven't investigated that.
    Well glad the main issue with phpmyadmin is solved now :)
  8. Guido64

    Guido64 Member

    Maybe related is wen i create a client acount and set this to dutch language (nl) and i create a site there is this default standard index.html in the root. Wen i explorer the ispconfig3 files in /usr/local/ispconfig/server/index/* there are standard index files in all languages iscpconfig3 supports also a dutch index version but wen i create a new site the default index page is english i wonder why since the dutch, german etc standard index files do exist.

Share This Page