please - how to remove ispconfig totally

Discussion in 'Installation/Configuration' started by dabeegmon, Aug 25, 2017.

  1. dabeegmon

    dabeegmon New Member

    Running Debian stretch. Wanting to use ispconfig3.1.6 initially.
    Installing using a recipe called 'The Perfect Server'
    on step 21:
    error message comes up:
    No PHP MySQLi functions available.
    Looked for what I could find using search engine duckduckgo and couldn't find anything to resolve this issue.
    Unresolvable issue - - - used first dpkg -r then dpkg -P AND apt remove and apt purge to clear my system of ispconfig.
    Always some error message.
    Next did an rm -r on /ispconfig.
    Still it is hanging in there. Tried using the dpkg AND apt removal procedures. Still there.
    Tried a reboot hoping that something might clear - - - no luck.
    Downloaded the tar files and unpacked followed by using $ php -q uninstall.php . Still hanging in there.
    How do I remove this non-functioning software?
    Does it take a system reinstall to wipe the system of ispconfig?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no problem with ISPConfig here, you just did not follow the installation tutorial closely. The error:

    No PHP MySQLi functions available.

    means that the PHP you are using has no MySQL support. MySQL support is installed in step 10 of the tutorial, you must have missed installing the php7.0-mysql package.

    apt-get -y install apache2 apache2-doc apache2-utils libapache2-mod-php php7.0 php7.0-common php7.0-gd php7.0-mysql php7.0-imap phpmyadmin php7.0-cli php7.0-cgi libapache2-mod-fcgid apache2-suexec-pristine php-pear php7.0-mcrypt mcrypt imagemagick libruby libapache2-mod-python php7.0-curl php7.0-intl php7.0-pspell php7.0-recode php7.0-sqlite3 php7.0-tidy php7.0-xmlrpc php7.0-xsl memcached php-memcache php-imagick php-gettext php7.0-zip php7.0-mbstring memcached libapache2-mod-passenger php7.0-soap
    So no unresolvable errors here, you should have simply asked to get help when you miss installing basic dependencies. That you did not found a solution in duckduckgo simply means that is is so uncommon that someone misses running this command from the tutorial.

    You messed up the system be deleting ispconfig files manually, so uninstall.php can not work then anymore and that you can not uninstall a software with apt that you have not installed with apt should be clear anyway.

    To resolve your issue, run the command to install the missing PHP packages and then run the ispconfig installer again to install ISPConfig.
  3. dabeegmon

    dabeegmon New Member

    Interesting - - - (!)

    Checked - - - - will copy some lines from the file that was saved which documents the series of steps (asking for your indulgence!)

    . . .
    Setting up php7.0-soap (7.0.19-1) . . .
    Setting up php7.0-mysql (7.0.19-1) . . .
    Setting up php7.0-readline (7.0.19-1) . . .
    . . .

    checked for installation by asking
    $apt install php7.0-mysql
    php7.0-mysql is already the newest version (7.0.19-1).

    the script suggested that running 'apt --fix-broken install' might help
    so I did
    The following additional packages will be installed:
    did the 20 questions routine for setup after the install was completed and then used cd to get to the directory where ispconfig is residing.
    further went to the 'install' directory inside ispconfig
    This is the directory where the install.php AND the uninstall.php files reside.
    Used php -q uninstall.php (I do want this thing to go away - - - - yes!!!)
    and ta da - - - its funky chicken time (for about the 6th time)
    PHP Warning: require_once( usr/local/ispconfig/server/lib/ failed to open stream: No such file or directory in /root/ispconfig3_install/install/uninstall.php on line 37
    PHP Fatal Error: require_once(): Failed opening required '/usr/local/ispconfig/server/lib/' (include_path='.:/usr/lib/php') in /root/ispconfig3_install/install/uninstall.php on line 37

    These lines suggest to me that something is still quite broken. php7.0-mysql IS installed, something is quite fubared so that configuration doesn't really complete. I would like a series of commands that will allow me to remove ispconfig and its associated files from my system - - - please.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    A clean uninstall is not possible anymore because you removed the /usr/local/ispconfig directory plus you installed some ispconfig .deb packages that are not from the ispconfig project.

    This package is nowhere installed in the perfect server guide and the ISPConfig project does not offer any .deb packages, so when you have such a package on your server then you could not have followed the perfect server tutorial. Either, you did not start from a clean server or you did not use the official installation instructions which install ISPConfig from tar.gz. I know you won't believe me as it must be ISPConfig's fault that your server is not working ;), so do a search in the tutorial yourself, you will nowhere find any instructions to install an ISPConfig .deb package in this tutorial. I know that there are some experimental .deb packages for ISPConfig not offered by the ISPConfig project which install an ISPConfig dev version and no release code, but that's not an official nor supported way to install ISPConfig.

    You completely messed up your system by mixing tutorials, so my recommendation is to reinstall the system. If you want to get a working ISPConfig server, then just follow this tutorial from start to end starting with a clean base setup and do not mix different guides or install ispconfig .deb packages offered on third party websites.
  5. dabeegmon

    dabeegmon New Member

    So a 'clean uninstall' isn't possible.
    How do I do an unclean one?

    FYI any .deb packages came from information on the ispconfig website.
    (download blahblah.tar.xz then do this and you will have a .deb file and you install that like this
    blah blah which I did in trying to affect an install.)
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Insert your OS boot media, reboot the system, delete the partitions and reinstall the OS. Or when your server is in a datacenter, login to the server control panel of your hosting provider and choose to reset the server OS.
  7. dabeegmon

    dabeegmon New Member

    OK so this needs a windows solution.
    Means that I just won't be trying to use ispconfig - - - - software written so that it can't even be uninstalled that puts it on a level that isn't a good place to be.
    Thankfully its on my equipment but it also means that there is another 8 or more hours of work to effect a reinstall.
    What a waste of time this exercise was - - - somehow the expectation seems to be that running this kind of software IS one's life. For me software is a tool that I use for other things. Thank you for that clarification!!
    Having worked for more than a wee while where I had to use tools where I couldn't see what I was doing and had to therefore learn to work through the machine as it were, I thought I understood remote tool setup and usage but software seems to not only be remote setup and usage seemingly approaching black box setup.
    (Here's the box - -- set it up like this, if it doesn't work - - - - that's your problem, good luck - - -- don't call us if you have problems we just sell this stuff.)
    Last edited: Aug 25, 2017
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I see that you still don't get the root of your problem, you did not even install the officially released Software ISPConfig, but complain here that the software that you installed and which was not released by the ISPConfig project did not work. Let me explain it from a windows users perspective, maybe you understand it then. If it would be Windows and not ISPConfig, then what you did was this:

    1) You downloaded a copy of Windows somewhere on the internet instead of getting an official install media from Microsoft. You installed that third party non-Microsoft release on your computer.
    2) This unofficial third party software messed up your computer, now you called the Microsoft support and complained there that the windows copy (which you did not got from Microsoft nor was released from Microsoft) messed up your server.

    So to sum it up:

    The software that you installed, which is not the ISPConfig stable release that the ISPconfig project is offering, can maybe not be uninstalled, it is not our release so I can't tell you what this software is doing. But the software that we offer, the ISPConfig stable tar.gz that you can download from, can be uninstalled (which won't be nescessary as it's install by using the perfect server guide would have worked anyway).

    Maybe yu learn something from it:

    1) Follow the official installation instructions of the software that you want to install.
    2) Download the official software from the website of that software instead of installing some third party packages.
    3) When you installed third party packages, then don't go to the official vendors forum to complain that the official software don't work (which you haven't installed).
  9. dabeegmon

    dabeegmon New Member

    Funny - - - what I'm learning is that:
    1.there are no good instructions on how to install complicated software (I was following that 'recipe' that was linked earlier and its featured on ispconfig's blog so maybe everything isn't wonderful in Oz)
    2. when you follow the instructions that are available and something doesn't work DON'T use the forums offered by that vendor for ideas on how to fix what isn't working
    3. don't bother asking questions because if you can't fix it you made a mistake and there is no way to find a fix (there aren't any!)

    By the way your security certificates are reading as not valid (again following the 'recipe' that your blog endorses) - - - - interesting that!
  10. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    If you really (and I mean really) knew what you are doing on your server, you would have followed the only official guides on how to install the server and ISPConfig on it – not some third-party-provided and maybe-maybenot-working packaging instructions.
    Instructions being available on a user-postable forum doesn't mean they were read or approved by admins or developers of ISPConfig, right?
    I'd be interested in the command that installs ispconfig-mariadb …
  11. dabeegmon

    dabeegmon New Member

    You may be thinking that I don't know how to read but you folks go one even better - - - - you haven't even read your own stuff!
    Installation instructions for ISPConfig 3
    its item #1 on the list - - - grin!

    So its on your server, included with your gargantuan amount of documentation and its not official - - - I wonder where I might find official documentation - - - - oh wait - - - - I'm supposed to pay for that. Sorry - - - - I won't buy a pig in a poke.

    (Please - - - - stop your coding, go to your nearest university, find the philosophy department and beg to take a course in logic - - - the hubris that is now being advanced is astounding and the lack of understanding of what is on your own website, well - - - - its parsecs past that. The command that installs ispconfig-mariadb - - - - $ apt install ispconfig-mariadb .)
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, that's indeed the official documentation. So if this tutorial tells you to install the package ispconfig-mariadb, then we are really stupid guys ;) You seem to be really confident that this tutorial instructs you to install a package with that name. Did you check it, I guess no. *grin*

    Ok, you found that command in the tutorial that you used. Really? You are so confident that you did not even check it, really funny.

    Wait, I've opened the first page of the guide, used the browser search to seek for 'ispconfig-mariadb', zero hits, the same on the second, no hits as well, and the same on the third page.

    We don't sell the official installation instructions for ISPConfig. You mix up the user manual (which shows you how to use ispconfig after installation) with the installation instructions.
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    This thread here is quite funny, but to make it a bit shorter, here is what you did:

    1) There is no ispconfig-mariadb package from nor is this package used in the official ISPConfig perfect server installation tutorials.
    2) You downloaded the ispconfig-mariadb package from

    As you can see, this is not the ISPConfig website nor do we provide these packages or use them in the official installation instructions. does not provide a forum as far as I know, so when you post here, then you are not posting in the vendor forum.
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the /etc/apt/sources.list fileon your server, You probably find the repository that you added there or it is in one of the files in /etc/apt/sources.list.d/
  15. dabeegmon

    dabeegmon New Member

    I never once said that I started with installing ispconfig-mariadb. You did!
    I went through the instructions you refer to above.
    Ended with an incomplete install/config session.

    Could find NO information re: possible issues on the 'official' website.

    See next - - -
  16. dabeegmon

    dabeegmon New Member

    As the developers of ispconfig your concern for your users is wonderful but as you have no information for what to do when something
    internal in the installation has gone awry one must needs look elsewhere.

    This site that you are deprecating was the only place where I could find something like the error message that I was getting.
    As there was/is NO other information available it logically suggested that it wouldn't make things any worse - - - things already weren't working and even at that point there was no way to uninstall ispconfig in any way or fashion. With nothing much to lose - - - I tried it.
    It worked not at all.

    So - - - - your team has a choice - - - - either provide a way to uninstall that works or you will likely find more people in time having issues. (Yes I read through the forums and found that my request wasn't a new one and it was/is answered as this one is.
    1. the user has done something wrong
    2. good luck finding a solution
    3. have a nice day

    if you spent as much time on writing software that works like a tool (can be used, discarded or not used at the choice of the user) you would not have to spend so much time responding to what you find to be demeaning.

    By the way - - - - I was able to delete ispconfig - - - - was not easy and quite tedious.
    How - - - - well - - - I will treat that like you do your documentation and offer it for a fee.
    Also - - - the recipe needs some tweaking as well.

    Good luck!!
  17. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Really: If you did, it would have worked.

    So thousands of users are wrong by using it and having a working ISPConfig :eek:

    It does unless you mess up things before. Oh, wait … you did.

    So you should have asked when getting the error messages and not after completely mess up.
  18. dabeegmon

    dabeegmon New Member

    (Some response interleaved in the quoted material.)
    Funny - - - most times the first thing I hear on a forum is - - - - 'why didn't you read xxxx or the yyyyyy' so I did - - -
    isipconfig doesn't believe in docs so that meant that I needed to look elsewhere. As things were already fubared what difference did that make.

    Don't worry - - - I won't be trying to use this 'software' any time soon - - - - its just not worth the time to get things working. I tend to use tools that let me work - - - not tools that make me devise new tools to fix the tool that I want to use.

Share This Page