Postfix: 554 5.7.1 Relay access denied

Discussion in 'Server Operation' started by Crog, Nov 29, 2007.

  1. Crog

    Crog New Member

    Hello all.

    Just recently I registered a domain name and I'm playing around with my server some more. Did a clean install of openSUSE 10.3 (following the perfect setup, didn't bother with ISPConfig).

    I'm doing something I've never done before, so setting up an email service on my home webserver is a new frontier for me (this is just to be a learning experience for now).

    I'd like it to be something like what most would expect from an email server: someone sends an email to <user> and that email is received by my server, as well as if a user on my server sends out an email (let's say to gmail/hotmail/yahoo/etc) that it be recognized that it was sent from <user>

    I used to test my all my DNS and Mail service stuff...and I come up with the following (edited my real domain name with

    Server Name
    IP	<my IP>
    Location	United States
    Mail Server For	*
    MX Priority	0
    Connect Response Time	883ms
    Server 'Hello' Line	220 ESMTP Postfix
    Open Relay?	No Problems Found
    RDNS Entry	<ISP-assigned hostname>.
    Mail Server info:
    Heads-up	The mail server rejected the email address '[email protected]' (554 5.7.1 <[email protected]>: Relay access denied). It should have accepted the address.
    Information	The mail server correctly rejected email to '[email protected]' (554 5.7.1 <[email protected]>: Relay access denied)
    Yesterday or the day before I tried to send out a test email from my server from the command line using: echo "Test message" | mail -s "Test message" <my gmail account> -- but I got something like
    -bash: mail: command not found
    <and something else that I can't remember, could've have also been that it didn't recognize "-s" as well>
    I then tried: echo "Test message" | <my gmail account> -- and it went through. I checked my gmail account and I got a message coming from root@, I then tried to reply to it from my gmail account but it quickly bounced back with the same "relay access denied" that I got from

    After playing around with some files, I now get
    -bash: mail: command not found
    -bash: echo: write error: Broken pipe
    I checked for guides everywhere and couldn't get it to work. Any help would be appreciated. If you need any of my config files or logs, let me know...would also appreciate it if you include the command to access the info that you might ask of me (since I'm a bit rusty...being a noob returning to linux after a year break). Thanks :D
  2. Crog

    Crog New Member

    Made some progress...

    I'm able to send mail from my outside email accounts (gmail/hotmail/etc) to my server when I address it to [email protected], but I'd like it to work with just [email protected], getting close though :p
  3. falko

    falko Super Moderator Howtoforge Staff

  4. djmixx07

    djmixx07 New Member

    I'm having that problem right now. I 1st got the Relay Access Denied error, but when I did "mydestination = /etc/postfix/local-host-names" it didn't gave that error anymore.

    But now my problem is my server cannot receive the emails from outside domains (Gmail/Yahoo/Hotmail/etc). It seems to send, but I don't know where it's going. If it gets lost, deleted, or stored somewhere -- I don't know! :confused:

    It's getting really frustrating and it's driving me crazy. Hope you guys can help. Thanks
  5. falko

    falko Super Moderator Howtoforge Staff

    Are there any errors in your mail log?

Share This Page