Postfix Catchall/Mail Receipt Problem

Discussion in 'Installation/Configuration' started by bkrausz, Jun 14, 2006.

  1. bkrausz

    bkrausz New Member

    I got a strange one for you guys:

    I have 2 websites setup, and
    I have [email protected] setup as a catchall
    I have [email protected] setup as an email address
    When I send an email to [email protected], it goes to [email protected], but when I send to [email protected] (nonexistant account) it bounces.

    I have tried the FAQ that recommends changing myhostname, it is currently set to, which I don't have any affiliation with, no good.

    # See /usr/share/postfix/ for a commented, more complete version
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    myhostname =
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination =,, , localhost
    relayhost =
    mynetworks =
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    virtualusertable has all the domains set correctly...the catchall is only set for


    Also: question: does it matter what the setting under Management -> Server -> Settings -> Domain is?
    Last edited: Jun 16, 2006
  2. falko

    falko Super Moderator Howtoforge Staff

    Can you post the real domains here?
    What's the output of
    hostname -f
    Any errors in the mail log?
  3. bkrausz

    bkrausz New Member

    Problem solved...removing logs for security's sake
    Last edited: Jun 16, 2006
  4. bkrausz

    bkrausz New Member

    I know I'm a bit impulsive and I do appologize, but I figured since I did mess up several other things, I may as well just redo my OS and get everything working right. Thanks for the help though...
  5. KCPoole

    KCPoole New Member

    Been there, Done that (Several times) :)

    now whenever I edit and config file, I always take a copy of it first! That way if I bork it up I can roll back to a working config easily.

    Another trick I learnt today, is to back up Mozilla config by installing "Google Browser Synch". If you have a google account, this saves the browser configs to their servers and lets you have multiple machines all synched. Can include cookies and website configs for you. That way if you have to blow the machine away as you are doing, you can recover the browser settings and site logins after you get back up and running


Share This Page