postfix - /home/vmail is not created

Discussion in 'Server Operation' started by jstd, Jun 7, 2011.

  1. jstd

    jstd New Member


    I'm following this HowTo:
    when I try to log in with squirrelmail, I get this ERROR: Connection dropped by IMAP server.

    The problem might be, that there are no files or directorys in /home/vmail

    Creating domains and mailadresses with Postfixadmin works perfectly fine (checked it with phpmyadmin), but no direcotrys are created.

    the logfile, while sending the welcome mail shows me:

    Jun  7 21:11:20 jstdEU postfix/smtpd[9265]: connect from localhost.localdomain[]
    Jun  7 21:11:20 jstdEU postfix/smtpd[9265]: 226E52108C24: client=localhost.localdomain[]
    Jun  7 21:11:20 jstdEU postfix/cleanup[9269]: 226E52108C24: message-id=<[email protected]>
    ,Jun  7 21:11:20 jstdEU postfix/smtpd[9265]: disconnect from localhost.localdomain[]
    Jun  7 21:11:20 jstdEU postfix/qmgr[9259]: 226E52108C24: from=<[email protected]>, size=598, nrcpt=1 (queue active)
    Jun  7 21:11:20 jstdEU postfix/error[9271]: 226E52108C24: to=<[email protected]/>, orig_to=<[email protected]>, relay=none, delay=0.81, delays=0.55/0.01/0/0.26, dsn=5.1.3, status=bounced (bad address syntax)
    Jun  7 21:11:20 jstdEU postfix/cleanup[9269]: E790C2108C28: message-id=<[email protected]>
    Jun  7 21:11:21 jstdEU postfix/qmgr[9259]: E790C2108C28: from=<>, size=2810, nrcpt=1 (queue active)
    Jun  7 21:11:21 jstdEU postfix/bounce[9272]: 226E52108C24: sender non-delivery notification: E790C2108C28
    Jun  7 21:11:21 jstdEU postfix/qmgr[9259]: 226E52108C24: removed
    Jun  7 21:11:21 jstdEU postfix/virtual[9274]: E790C2108C28: to=<[email protected]>, relay=virtual, delay=0.35, delays=0.21/0.01/0/0.13, dsn=5.1.1, status=bounced (unknown user: "[email protected]")
    Jun  7 21:11:21 jstdEU postfix/qmgr[9259]: E790C2108C28: removed
    # See /usr/share/postfix/ for a commented, more complete version
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    readme_directory = no
    # TLS parameters
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    myhostname =
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    mydestination =
    relayhost =
    mynetworks = [::ffff:]/104 [::1]/128
    #mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    # Virtual Mailbox Domain Settings
    virtual_alias_maps = mysql:/etc/postfix/
    virtual_mailbox_domains = mysql:/etc/postfix/
    virtual_mailbox_maps = mysql:/etc/postfix/
    virtual_mailbox_limit = 51200000
    virtual_minimum_uid = 5000
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    virtual_mailbox_base = /home/vmail
    virtual_transport = virtual
    # Additional for quota support
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = mysql:/etc/postfix/
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = Sorry, the your maildir has overdrawn your diskspace quo$
    virtual_overquota_bounce = yes
    vmail is owner of /home/vmail:
    cd /home
    chown -R vmail.vmail vmail
    Can anyone help?
    Thanks, johannes

    P.s.: I skipped the part installing and setting up SMTP authentication, but I thinks thats fine...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The directory is created by postfix when the first email arrives in the mailbox.
  3. jstd

    jstd New Member

    well, exactly this is the problem.
    It is NOT created and the mail is not delivered --> see "status=bounced (bad address syntax" in the logfile
  4. yasuni

    yasuni New Member

    chek if vmail is owend bij vmail

    root@localhost#ls -la /home
    drwx------   5 vmail                  vmail                   4096 Jun  9 20:47 vmail
  5. nzimas

    nzimas Member

    Last edited: Dec 21, 2012
  6. nzimas

    nzimas Member

    Found the point of failure, although it should not happen.

    According to the postfix log:[]:10024: Connection refused

    However, telnet tells a different tale:
    root@langata:/usr/src# telnet 25
    Connected to
    Escape character is '^]'.
    220 ESMTP Postfix (Ubuntu)

    I'm puzzled.
  7. falko

    falko Super Moderator Howtoforge Staff

    Looks like amavisd (which should be running on port 10024) isn't running. Please restart it.
  8. nzimas

    nzimas Member

    Amavis is definitely running and listening on port 10024

    root@langata:/home/administrator# netstat -tap | grep amavis
    tcp        0      0 localhost:10024         *:*                     LISTEN      1697/amavisd (maste
  9. falko

    falko Super Moderator Howtoforge Staff

    Please restart it and try again.

    Did you check if your server is running out of memory?

Share This Page