Postfix not sending/receiving mails without Amavis

Discussion in 'Installation/Configuration' started by PSKart, Oct 20, 2022.

  1. PSKart

    PSKart New Member

    Hello Team,
    My goal was to disable Amavis and ClamAV for lowering my RAM consumption.
    1. Commented lines in /etc/postfix/ - restarted postfix .
    I have followed the instructions here (
    When I sent a test email I found this in the logs "Sender address triggers FILTER amavis:[]:10026; "
    I have found no trace of port 10026 in any postfix configuration files ( /

    2. I tried commenting a reference on Amavis in and restarting (commenting Amavis lines)
    The same thing in the log messages, sender address triggers Amavis.
    The curious thing
    Only after I reload the postfix configuration (postfix reload) and requeue emails (postsuper -r ALL) the emails are being sent - but only those that failed to be sent. If I send another email after reloading and requeing, I get the same problem of triggering the amavis filter. It only gets solved after manually requeing emails again.

    3. Tried system reboot. Tried multiple service restarts (postfix, amavis). Same thing

    I don't understand
    • Where is a reference of port 10026 in any postfix configuration?
    • Why are emails being sent only after manual requeue ?
    I did installed the DKIM patch. Just 10-12 Days before I updated to ISPConfig Version: 3.2.8p2.
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Did you try:
    grep -r 10026 /etc/postfix/
    I believe it is Amavis that does DKIM signing, so DKIM may not work if you remove amavis.
    I recommend adding swap, for example 4 GB, to that host and keep amavis and clamav.
    ahrasis likes this.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

  4. PSKart

    PSKart New Member

    Here is the output
    root@server:~# grep -r 10026 /etc/postfix/
    /etc/postfix/^/ FILTER lmtp:[]:10026
    /etc/postfix/^/ FILTER lmtp:[]:10026

Share This Page