Postfix refuses to run without Amavis filtering and manual requeue

Discussion in 'Installation/Configuration' started by victortruica, Sep 19, 2015.

  1. victortruica

    victortruica New Member

    My goal was to disable amavis and clamav for lowering my RAM consumption. I've noticed this subject being covered in several forum posts and I've understood how it is done. The problem is does not work as expected.

    1. Commented lines in /etc/postfix/ - restarted postfix .
    I have followed the instructions here (
    When I sent a test email I found this in the logs "Sender address triggers FILTER amavis:[]:10026; "
    I have found no trace of port 10026 in any postfix configuration files ( /

    2. I tried commenting a reference on amavis in and restarting postfix according to the instructions here (
    The same thing in the log messages, sender address triggers amavis.

    The curious thing

    Only after I reload the postfix configuration (postfix reload) and requeue emails (postsuper -r ALL) the emails are being sent - but only those that failed to be sent. If I send another email after reloading and requeing, I get the same problem of triggering the amavis filter. It only gets solved after manually requeing emails again.

    3. Tried system reboot. Tried multiple service restarts (postfix, amavis). Same thing

    I don't understand
    • Where is a reference of port 10026 in any postfix configuration?
    • Why are emails being sent only after manual requeue ?
    I have a feeling that some configuration (maybe in ISPconfig3, I have no idea) overwrites some parameters in the post configuration.

    More info
    • mail receiving log sample (triggered amavis on both 10024 and 10026 ports) -

    Any ideas ?
    Last edited: Sep 19, 2015
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you installed the skim patch which adds additional ports and filters in postfix, the faqforge article is about a normal ispconfig install without dkim. You will have to undo the dkim modifications as well if you want to turn off Amavisd.
  3. victortruica

    victortruica New Member

    Thanks for the quick reply till!

    You are right, I did installed the DKIM patch ( and as I can see there, the DKIM signing is done through amavis.

    Will return with an update if uninstalling the DKIM patch made it possible to solve my problem.
    Last edited: Sep 19, 2015
  4. florian030

    florian030 Well-Known Member HowtoForge Supporter

    To full disable amavis remove the tag_as - settings from the, too.
  5. victortruica

    victortruica New Member

    I ended up reverting the changes made by the DKIM patch to postfix, copying / to /

    It works now. Thanks for the suggestions!

Share This Page