Postfix + Sasl2 problem on Mandriva 2009 (64bit)

Discussion in 'Installation/Configuration' started by feablee, Dec 10, 2008.

  1. feablee

    feablee New Member

    Hi, I followed tutorial Perfect server on Mandriva 2009 (x86_64) - point Postfix + Sasl2. I've installed and configured both but when I try send mail with authentiction Im getting in logs:

    ... kernel: saslauthd segfault at .....  error 4 in ... 
    warning: SASL authentication failure: size read failed
    Have You seen it before?
  2. falko

    falko Super Moderator Howtoforge Staff

    Not sure what it is. Have you tried to reinstall saslauthd?
  3. feablee

    feablee New Member

    Yes,I tried many times to urpme it and install from another repository. Unfortunatelly lib64-sasl is part of system-base and cant remove it easly and install some other version.
    Do you know how authenticate smtp with dovecot on Mandriva 2009 - is it possible? I dont mean pop3 authentication.

  4. falko

    falko Super Moderator Howtoforge Staff

    SMTP authentication is possible with Dovecot, but I haven't tried it yet.
  5. Eagle

    Eagle New Member

    I followed perfect setup tutorial step by step and I have same problem as feablee.
    Mandriva 2009 x86_64, postfix, sasl.

    postfix/smtpd[15361]: warning: SASL authentication failure: size read failed
    postfix/smtpd[15361]: warning: SASL authentication failure: Password verification failed
    postfix/smtpd[15361]: warning: unknown[]: SASL PLAIN authentication failed: generic failure
    postfix/smtpd[15361]: warning: SASL authentication failure: cannot connect to saslauthd server: Connection refused
    postfix/smtpd[15361]: warning: unknown[]: SASL LOGIN authentication failed: generic failure

    Authentication method is pam, but kerberos5 or shadow also don't work.
  6. falko

    falko Super Moderator Howtoforge Staff

    What's in /etc/sasl2/smtpd.conf and /etc/sysconfig/saslauthd?

    Can you make the Postfix user a member of the saslauth group and restart Postfix and saslauthd?
  7. muchal

    muchal New Member

    Mandriva 2009 64bit Postfix and Sasl problem

    Hi !

    I have followed The Perfect Server - Mandriva 2009.0 Free (x86_64) and in the step 11 Postfix With SMTP-AUTH And TLS; Dovecot when I telnet localhost 25 connection is dropped instantly by the postfix server and the mail error.log says something like: "no SASL authentication mechanism"

    I'm stuck any ideas ?
  8. falko

    falko Super Moderator Howtoforge Staff

    What's in /etc/sasl2/smtpd.conf and /etc/sysconfig/saslauthd?
  9. muchal

    muchal New Member

    I 'fixed' it, somehow I have installed wrong RPMs .
    Started over and now I got STARTTLS and AUTH PLAIN ....

    Now I will try to install ispconfig 3

    Thanks and sorry for confusion !
  10. muchal

    muchal New Member

    Possible workaround for this issue

    Here is the story with pam authentication saslauthd will only authenticate once and the it will die with saslauthd[3383]: server_exit : master exited: 3383

    With shadow it will fail with segfault at fffffffff9bf82a0 ip 00007f2cf8ce0a80 sp 00007fff020d59d8 error 4 in[7f2cf8c64000+158000]

    the workaround that worked for me was:
    edit /etc/sysconfig/saslauthd
    -c - cache credentials
    -V is a verbose logging, so you may skip it and try just SASLAUTHD_OPTS='-c'
    let me know if it worked for you guys!

    ps. when saslauthd dies it wont cleanup the communication socket, to clean it run: service saslauthd stop and then service saslauthd start
    and verify with: ls -l /var/lib/sasl2/ /var/spool/postfix/var/lib/sasl2/
    Last edited: Feb 11, 2009

Share This Page