Postfix UPGRADED: Virtual Users And Domains With Postfix, Courier, MySQL And Squirrel

Discussion in 'Server Operation' started by stealthy, Jan 20, 2013.

  1. stealthy

    stealthy New Member

    I have followed Falko's tutorial .

    The interestting part was to have user quotas.

    Then, without a though I ran apt-get upgrade and this upgraded my patched Postfix. Ooops.

    Now, every time I restart Postfix, I get these warnings that "....warning: /etc/postfix/ unused parameter: virtual_overquota_bounce=yes....."

    I am afraid I messed up the quota patch. Any suggestions?
  2. suntribe

    suntribe New Member

    I had the same scenario and at the end, I decided to go without the quota... I simply removed those unrecognized parameters from Postfix config file and now everything is working...
  3. stealthy

    stealthy New Member

    Same here. The setup still works. I guess I could go back, recompile the old version....... DON'T FIX IT IF AIN'T BROKE!
  4. stealthy

    stealthy New Member

    Does this setup really work? That's a good question.

    I see a header in the received emails that says X-Virus-Scanned: Debian amavisd-new at

    I don't see any headers with reference to SPAM, spam score, SpamAssassin. So I am NOT convinced that SA is running properly.

    More so because yesterday I received a spam message that shouldn't have gotten through at all.

    Would anyone here have a suggestion how to add the SpamAssassin headers into the messages and make sure that SA works?

  5. stealthy

    stealthy New Member

    If you want to force the X-SPAM headers, you need to edit /etc/amavis/conf.d/50-user
    by adding this line:
    @local_domains_acl = ( "." );
    And this is how it looks in the email message headers:
    X-Virus-Scanned: Debian amavisd-new at my.awesome.tld
    X-Spam-Flag: NO
    X-Spam-Score: -1.1
    X-Spam-Status: No, score=-1.1 tagged_above=-9999 required=6.31
    	tests=[ALL_TRUSTED=-1, DKIM_SIGNED=0.1, DKIM_VALID=-0.1,
    	DKIM_VALID_AU=-0.1] autolearn=ham
    Last edited: Jan 27, 2013
  6. stealthy

    stealthy New Member

    Here is excerpt from my log, a message I tried sending to myself with some common spam words (like pharma):

    Jan 27 09:42:58 myhostname amavis[6658]: (06658-01) Blocked SPAM {DiscardedInbound,Quarantined}, []:58187 [] <[email protected]> -> <[email protected]>, quarantine: z/spam-zRf-0a_2SC1x.gz, Queue-ID: 4FF02276FB, Message-ID: <[email protected]>, mail_id: zRf-0a_2SC1x, Hits: 6.393, size: 1617,, 1938 ms
    Jan 27 09:42:58 myhostname postfix/smtp[6705]: 4FF02276FB: to=<[email protected]>, relay=[]:10024, delay=4.3, delays=2.3/0.07/0.02/1.9, dsn=2.7.0, status=sent (250 2.7.0 Ok, discarded, id=06658-01 - spam)
    Thumbs up!

    I still need to learn more about using SpamAssassin.

Share This Page